aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index b82d54b0f6..5902eee6ac 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -201,6 +201,19 @@ define Device/qcom_ipq8064-ap148-legacy
endef
TARGET_DEVICES += qcom_ipq8064-ap148-legacy
+define Device/qcom_ipq8064-ap161
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_DTS := qcom-ipq8064-ap161
+ KERNEL_INSTALL := 1
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ BOARD_NAME := ap161
+ DEVICE_TITLE := Qualcomm AP161
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
+endef
+TARGET_DEVICES += qcom_ipq8064-ap161
+
define Device/qcom_ipq8064-db149
$(call Device/FitImage)
DEVICE_DTS := qcom-ipq8064-db149