aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index c59e6d446e..14cf442f43 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -47,8 +47,9 @@ define Device/Default
KERNEL_PREFIX := $$(IMAGE_PREFIX)
IMAGES :=
KERNEL_IN_UBI :=
+ BOARD_NAME :=
endef
-DEVICE_VARS += DEVICE_DTS KERNEL_IN_UBI
+DEVICE_VARS += DEVICE_DTS KERNEL_IN_UBI BOARD_NAME
define Device/LegacyImage
KERNEL_SUFFIX := -uImage
@@ -78,12 +79,11 @@ define Device/DniImage
KERNEL_NAME := zImage
NETGEAR_BOARD_ID :=
NETGEAR_HW_ID :=
- BOARD_NAME :=
IMAGES := factory.img sysupgrade.tar
IMAGE/factory.img := append-kernel | append-ubi | netgear-dni
IMAGE/sysupgrade.tar = sysupgrade-nand
endef
-DEVICE_VARS += KERNEL_SIZE NETGEAR_BOARD_ID NETGEAR_HW_ID DEVICE_BLOCK_SIZE DEVICE_PAGE_SIZE BOARD_NAME
+DEVICE_VARS += KERNEL_SIZE NETGEAR_BOARD_ID NETGEAR_HW_ID DEVICE_BLOCK_SIZE DEVICE_PAGE_SIZE
define Device/AP148
$(call Device/FitImage)
@@ -91,6 +91,7 @@ define Device/AP148
DEVICE_DTS := qcom-ipq8064-ap148
BLOCKSIZE := 128KiB
PAGESIZE := 2048
+ BOARD_NAME := ap148
endef
define Device/AP148-legacy
@@ -99,13 +100,14 @@ define Device/AP148-legacy
DEVICE_DTS := qcom-ipq8064-ap148
BLOCKSIZE := 128KiB
PAGESIZE := 2048
- BOARD_NAME := AP148
+ BOARD_NAME := ap148
endef
define Device/DB149
$(call Device/FitImage)
DEVICE_DTS := qcom-ipq8064-db149
KERNEL_INSTALL := 1
+ BOARD_NAME := db149
endef
define Device/R7500