aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index d41679ff97..73b6ca8c34 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -34,8 +34,8 @@ endef
define Device/UbiFit
KERNEL_IN_UBI := 1
- IMAGES := nand-factory.ubi nand-sysupgrade.bin
- IMAGE/nand-factory.ubi := append-ubi
+ IMAGES := nand-factory.bin nand-sysupgrade.bin
+ IMAGE/nand-factory.bin := append-ubi
IMAGE/nand-sysupgrade.bin := sysupgrade-tar | append-metadata
endef
@@ -73,6 +73,17 @@ define Device/ZyXELImage
IMAGE/mmcblk0p4-kernel.bin := append-kernel
endef
+define Device/compex_wpq864
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ DEVICE_DTS := qcom-ipq8064-wpq864
+ DEVICE_TITLE := Compex WPQ864
+ DEVICE_PACKAGES := kmod-gpio-beeper
+endef
+TARGET_DEVICES += compex_wpq864
+
define Device/linksys_ea8500
$(call Device/LegacyImage)
DEVICE_DTS := qcom-ipq8064-ea8500