aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq40xx/modules.mk')
-rw-r--r--target/linux/ipq40xx/modules.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/modules.mk b/target/linux/ipq40xx/modules.mk
new file mode 100644
index 0000000000..43f3c9cfe7
--- /dev/null
+++ b/target/linux/ipq40xx/modules.mk
@@ -0,0 +1,33 @@
+define KernelPackage/usb-dwc3-of-simple
+ TITLE:=DWC3 USB simple OF driver
+ DEPENDS:=+kmod-usb-dwc3
+ KCONFIG:= CONFIG_USB_DWC3_OF_SIMPLE
+ FILES:= $(LINUX_DIR)/drivers/usb/dwc3/dwc3-of-simple.ko
+ AUTOLOAD:=$(call AutoLoad,53,dwc3-of-simple,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-dwc3-of-simple/description
+ This driver provides generic platform glue for the integrated DesignWare
+ USB3 IP Core.
+endef
+
+$(eval $(call KernelPackage,usb-dwc3-of-simple))
+
+define KernelPackage/usb-phy-qcom-dwc3
+ TITLE:=DWC3 USB QCOM PHY driver
+ DEPENDS:=@TARGET_ipq806x +kmod-usb-dwc3-of-simple
+ KCONFIG:= CONFIG_PHY_QCOM_DWC3
+ FILES:= \
+ $(LINUX_DIR)/drivers/phy/phy-qcom-dwc3.ko@lt4.13 \
+ $(LINUX_DIR)/drivers/phy/qualcomm/phy-qcom-dwc3.ko@ge4.13
+ AUTOLOAD:=$(call AutoLoad,45,phy-qcom-dwc3,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-phy-qcom-dwc3/description
+ This driver provides support for the integrated DesignWare
+ USB3 IP Core within the QCOM SoCs.
+endef
+
+$(eval $(call KernelPackage,usb-phy-qcom-dwc3))