aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/generic.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index c24eb28523..0d7d7a30d2 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -46,6 +46,17 @@ define Build/append-rootfshdr
dd if=$@.new bs=64 count=1 >> $(IMAGE_KERNEL)
endef
+define Build/append-rutx-metadata
+ echo \
+ '{ \
+ "device_code": [".*"], \
+ "hwver": [".*"], \
+ "batch": [".*"], \
+ "serial": [".*"], \
+ "supported_devices":["teltonika,rutx"] \
+ }' | fwtool -I - $@
+endef
+
define Build/mkmylofw_32m
$(eval device_id=$(word 1,$(1)))
$(eval revision=$(word 2,$(1)))
@@ -873,6 +884,22 @@ define Device/qxwlan_e2600ac-c2
endef
TARGET_DEVICES += qxwlan_e2600ac-c2
+define Device/teltonika_rutx10
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_VENDOR := Teltonika
+ DEVICE_MODEL := RUTX10
+ SOC := qcom-ipq4018
+ DEVICE_DTS_CONFIG := config@5
+ KERNEL_INSTALL := 1
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ FILESYSTEMS := squashfs
+ IMAGE/nand-factory.ubi := append-ubi | qsdk-ipq-factory-nand | append-rutx-metadata
+ DEVICE_PACKAGES := ipq-wifi-teltonika_rutx kmod-bluetooth
+endef
+TARGET_DEVICES += teltonika_rutx10
+
define Device/unielec_u4019-32m
$(call Device/FitImage)
DEVICE_VENDOR := Unielec