aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq40xx/image/generic.mk')
-rw-r--r--target/linux/ipq40xx/image/generic.mk13
1 files changed, 10 insertions, 3 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 08cbd63b3c..99a9b78b78 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -1164,7 +1164,6 @@ TARGET_DEVICES += zte_mf286d
define Device/zte_mf287_common
$(call Device/zte_mf28x_common)
- DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
SOC := qcom-ipq4018
# The recovery image is used to return back to stock (an initramfs-based image
# that can be flashed to the device via sysupgrade
@@ -1177,15 +1176,23 @@ endef
define Device/zte_mf287plus
$(call Device/zte_mf287_common)
+ DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
DEVICE_MODEL := MF287Plus
- DEVICE_ALT0_VENDOR := ZTE
- DEVICE_ALT0_MODEL := MF287
endef
TARGET_DEVICES += zte_mf287plus
+define Device/zte_mf287
+ $(call Device/zte_mf287_common)
+ DEVICE_PACKAGES += ipq-wifi-zte_mf287
+ DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+ DEVICE_MODEL := MF287
+endef
+TARGET_DEVICES += zte_mf287
+
define Device/zte_mf287pro
$(call Device/zte_mf287_common)
+ DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
DEVICE_DTS_CONFIG := config@ap.dk04.1-c1
DEVICE_MODEL := MF287Pro
endef