aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq40xx/image/generic.mk')
-rw-r--r--target/linux/ipq40xx/image/generic.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 671fca1682..b9e9e478d9 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -1148,6 +1148,24 @@ define Device/zte_mf286d
endef
TARGET_DEVICES += zte_mf286d
+define Device/zte_mf287plus
+ $(call Device/zte_mf28x_common)
+ DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+ DEVICE_MODEL := MF287Plus
+ DEVICE_ALT0_VENDOR := ZTE
+ DEVICE_ALT0_MODEL := MF287
+ DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
+ SOC := qcom-ipq4018
+# The recovery image is used to return back to stock (an initramfs-based image
+# that can be flashed to the device via sysupgrade
+# The factory image is used to install from the stock firmware by using an
+# exploit for the web interface
+ IMAGES += factory.bin recovery.bin
+ IMAGE/factory.bin := append-ubi
+ IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/openwrt-$$(BOARD)$$(if $$(SUBTARGET),-$$(SUBTARGET))-$$(DEVICE_NAME)-initramfs-zImage.itb rootfs=$$$$@ | append-metadata
+endef
+TARGET_DEVICES += zte_mf287plus
+
define Device/zte_mf289f
$(call Device/zte_mf28x_common)
DEVICE_MODEL := MF289F