aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq40xx/image/generic.mk')
-rw-r--r--target/linux/ipq40xx/image/generic.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index aa013e8e61..dcf0cb20aa 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -720,6 +720,23 @@ define Device/linksys_mr8300
endef
TARGET_DEVICES += linksys_mr8300
+define Device/linksys_whw03v2
+ $(call Device/FitzImage)
+ DEVICE_VENDOR := Linksys
+ DEVICE_MODEL := WHW03
+ DEVICE_VARIANT := V2
+ SOC := qcom-ipq4019
+ KERNEL_SIZE := 6144k
+ IMAGE_SIZE := 158720k
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ UBINIZE_OPTS := -E 5 # EOD marks to "hide" factory sig at EOF
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=WHW03v2
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-linksys_whw03v2 kmod-leds-pca963x kmod-spi-dev kmod-bluetooth
+endef
+TARGET_DEVICES += linksys_whw03v2
+
define Device/linksys_whw01
$(call Device/FitzImage)
DEVICE_VENDOR := Linksys