aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq40xx/image/Makefile')
-rw-r--r--target/linux/ipq40xx/image/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 5e6bd1d1b7..1d9f20b85f 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -378,6 +378,20 @@ define Device/engenius_emd1
endef
TARGET_DEVICES += engenius_emd1
+define Device/engenius_emr3500
+ $(call Device/FitImage)
+ DEVICE_VENDOR := EnGenius
+ DEVICE_MODEL := EMR3500
+ DEVICE_DTS_CONFIG := config@4
+ SOC := qcom-ipq4018
+ KERNEL_SIZE := 4096k
+ IMAGE_SIZE := 30720k
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+ IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
+endef
+TARGET_DEVICES += engenius_emr3500
+
define Device/engenius_ens620ext
$(call Device/FitImage)
DEVICE_VENDOR := EnGenius