aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq40xx/image/Makefile')
-rw-r--r--target/linux/ipq40xx/image/Makefile39
1 files changed, 38 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 588a24c2fe..41a65280c3 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -1,7 +1,8 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-DEVICE_VARS += RAS_BOARD RAS_ROOTFS_SIZE RAS_VERSION
+DEVICE_VARS += RAS_BOARD RAS_ROOTFS_SIZE RAS_VERSION \
+ WRGG_DEVNAME WRGG_SIGNATURE
define Device/Default
PROFILES := Default
@@ -61,6 +62,15 @@ define Build/SenaoFW
@cp $@.new $@
endef
+define Build/wrgg-image
+ mkwrggimg -i $@ \
+ -o $@.new \
+ -d "$(WRGG_DEVNAME)" \
+ -s "$(WRGG_SIGNATURE)" \
+ -v "" -m "" -B ""
+ mv $@.new $@
+endef
+
define Device/8dev_jalapeno-common
$(call Device/FitImage)
$(call Device/UbiFit)
@@ -227,6 +237,33 @@ define Device/compex_wpj428
endef
TARGET_DEVICES += compex_wpj428
+define Device/dlink_dap-2610
+ $(call Device/FitImageLzma)
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DAP-2610
+ SOC := qcom-ipq4018
+ DEVICE_DTS_CONFIG := config@ap.dk01.1-c1
+ BLOCKSIZE := 64k
+ WRGG_DEVNAME := /dev/mtdblock/8
+ WRGG_SIGNATURE := wapac30_dkbs_dap2610
+ IMAGE_SIZE := 14080k
+ IMAGES := sysupgrade.bin factory.bin
+ # Bootloader expects a special 160 byte header which is added by
+ # wrgg-image.
+ # Factory image size must be larger than 6MB, and size in wrgg header must
+ # match actual factory image size to be flashable from D-Link http server.
+ # Bootloader verifies checksum of wrgg image before booting, thus jffs2
+ # cannot be part of the wrgg image. This is solved in the factory image by
+ # having the rootfs at the end of the image (without pad-rootfs). And in
+ # the sysupgrade image only the kernel is included in the wrgg checksum,
+ # but this is not flashable from the D-link http server.
+ # append-rootfs must start on an erase block boundary.
+ IMAGE/factory.bin := append-kernel | pad-offset 6144k 160 | append-rootfs | wrgg-image | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin := append-kernel | wrgg-image | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | append-metadata
+ DEVICE_PACKAGES := ipq-wifi-dlink_dap2610
+endef
+TARGET_DEVICES += dlink_dap-2610
+
define Device/engenius_eap1300
$(call Device/FitImage)
DEVICE_VENDOR := EnGenius