aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq40xx/image/Makefile')
-rw-r--r--target/linux/ipq40xx/image/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index a9c5e625af..ac34447475 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -60,14 +60,18 @@ define Build/SenaoFW
@cp $@.new $@
endef
-define Device/8dev_jalapeno
+define Device/8dev_jalapeno-common
$(call Device/FitImage)
$(call Device/UbiFit)
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+endef
+
+define Device/8dev_jalapeno
+ $(call Device/8dev_jalapeno-common)
DEVICE_VENDOR := 8devices
DEVICE_MODEL := Jalapeno
DEVICE_DTS := qcom-ipq4018-jalapeno
- BLOCKSIZE := 128k
- PAGESIZE := 2048
endef
TARGET_DEVICES += 8dev_jalapeno
@@ -164,6 +168,15 @@ define Device/avm_fritzrepeater-3000
endef
TARGET_DEVICES += avm_fritzrepeater-3000
+define Device/cilab_meshpoint-one
+ $(call Device/8dev_jalapeno-common)
+ DEVICE_DTS := qcom-ipq4018-meshpoint-one
+ DEVICE_VENDOR := Crisis Innovation Lab
+ DEVICE_MODEL := MeshPoint.One
+ DEVICE_PACKAGES := kmod-i2c-gpio kmod-iio-bmp280-i2c kmod-hwmon-ina2xx kmod-rtc-pcf2127
+endef
+TARGET_DEVICES += cilab_meshpoint-one
+
define Device/compex_wpj419
$(call Device/FitImage)
$(call Device/UbiFit)