aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq40xx/image/Makefile')
-rw-r--r--target/linux/ipq40xx/image/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 218a80afa7..dd71746cc0 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -31,6 +31,27 @@ define Device/UbiFit
IMAGE/nand-sysupgrade.bin := sysupgrade-tar | append-metadata
endef
+
+define Device/asus_rt-ac58u
+ $(call Device/FitImageLzma)
+ DEVICE_DTS := qcom-ipq4018-rt-ac58u
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ DTB_SIZE := 65536
+ DEVICE_TITLE := Asus RT-AC58U
+ IMAGE_SIZE := 20439364
+ FILESYSTEMS := squashfs
+# Someone - in their infinite wisdom - decided to put the firmware
+# version in front of the image name \03\00\00\04 => Version 3.0.0.4
+# Since u-boot works with strings we either need another fixup step
+# to add a version... or we are very careful not to add '\0' into that
+# string and call it a day.... Yeah, we do the latter!
+ UIMAGE_NAME:=$(shell echo -e '\03\01\01\01RT-AC58U')
+ IMAGES := sysupgrade.bin
+ DEVICE_PACKAGES := ipq-wifi-asus_rt-ac58u kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += asus_rt-ac58u
+
define Device/avm_fritzbox-4040
$(call Device/FitImageLzma)
DEVICE_DTS := qcom-ipq4019-fritz4040