aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/image/Makefile')
-rw-r--r--target/linux/image/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/image/Makefile b/target/linux/image/Makefile
index ce807b3027..3b82343398 100644
--- a/target/linux/image/Makefile
+++ b/target/linux/image/Makefile
@@ -33,11 +33,11 @@ install-ib:
$(CP) $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/kernel[-_]*.ipk $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)/
install-prepare:
- find $(KDIR)/root -type f -not -perm +0100 | xargs chmod 0644
- find $(KDIR)/root -type f -perm +0100 | xargs chmod 0755
- find $(KDIR)/root -type d | xargs chmod 0755
- mkdir -p $(KDIR)/root/tmp
- chmod 0777 $(KDIR)/root/tmp
+ find $(BUILD_DIR)/root -type f -not -perm +0100 | xargs chmod 0644
+ find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
+ find $(BUILD_DIR)/root -type d | xargs chmod 0755
+ mkdir -p $(BUILD_DIR)/root/tmp
+ chmod 0777 $(BUILD_DIR)/root/tmp
rebuild: clean prepare compile install
clean: