aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/pending-3.18/730-phy_b53.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/pending-3.18/730-phy_b53.patch')
-rw-r--r--target/linux/generic/pending-3.18/730-phy_b53.patch60
1 files changed, 0 insertions, 60 deletions
diff --git a/target/linux/generic/pending-3.18/730-phy_b53.patch b/target/linux/generic/pending-3.18/730-phy_b53.patch
deleted file mode 100644
index 8137693b3c..0000000000
--- a/target/linux/generic/pending-3.18/730-phy_b53.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -282,6 +282,8 @@ config RTL8367B_PHY
-
- endif # RTL8366_SMI
-
-+source "drivers/net/phy/b53/Kconfig"
-+
- endif # PHYLIB
-
- config MICREL_KS8995MA
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -31,6 +31,7 @@ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
- obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
- obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_PSB6970_PHY) += psb6970.o
-+obj-$(CONFIG_SWCONFIG_B53) += b53/
- obj-$(CONFIG_FIXED_PHY) += fixed.o
- obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
- obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o
---- /dev/null
-+++ b/linux/platform_data/b53.h
-@@ -0,0 +1,36 @@
-+/*
-+ * B53 platform data
-+ *
-+ * Copyright (C) 2013 Jonas Gorski <jogo@openwrt.org>
-+ *
-+ * Permission to use, copy, modify, and/or distribute this software for any
-+ * purpose with or without fee is hereby granted, provided that the above
-+ * copyright notice and this permission notice appear in all copies.
-+ *
-+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
-+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
-+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
-+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
-+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
-+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
-+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
-+ */
-+
-+#ifndef __B53_H
-+#define __B53_H
-+
-+#include <linux/kernel.h>
-+
-+struct b53_platform_data {
-+ u32 chip_id;
-+ u16 enabled_ports;
-+
-+ /* allow to specify an ethX alias */
-+ const char *alias;
-+
-+ /* only used by MMAP'd driver */
-+ unsigned big_endian:1;
-+ void __iomem *regs;
-+};
-+
-+#endif