aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.9/904-debloat_dma_buf.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-4.9/904-debloat_dma_buf.patch')
-rw-r--r--target/linux/generic/patches-4.9/904-debloat_dma_buf.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.9/904-debloat_dma_buf.patch b/target/linux/generic/patches-4.9/904-debloat_dma_buf.patch
new file mode 100644
index 0000000000..91a3870936
--- /dev/null
+++ b/target/linux/generic/patches-4.9/904-debloat_dma_buf.patch
@@ -0,0 +1,51 @@
+--- a/drivers/base/Kconfig
++++ b/drivers/base/Kconfig
+@@ -241,7 +241,7 @@ config SOC_BUS
+ source "drivers/base/regmap/Kconfig"
+
+ config DMA_SHARED_BUFFER
+- bool
++ tristate
+ default n
+ select ANON_INODES
+ help
+--- a/drivers/dma-buf/Makefile
++++ b/drivers/dma-buf/Makefile
+@@ -1,3 +1,7 @@
+-obj-y := dma-buf.o fence.o reservation.o seqno-fence.o fence-array.o
+-obj-$(CONFIG_SYNC_FILE) += sync_file.o
+-obj-$(CONFIG_SW_SYNC) += sw_sync.o sync_debug.o
++obj-$(CONFIG_DMA_SHARED_BUFFER) := dma-shared-buffer.o
++
++dma-buf-objs-y := dma-buf.o fence.o reservation.o seqno-fence.o fence-array.o
++dma-buf-objs-$(CONFIG_SYNC_FILE) += sync_file.o
++dma-buf-objs-$(CONFIG_SW_SYNC) += sw_sync.o sync_debug.o
++
++dma-shared-buffer-objs := $(dma-buf-objs-y)
+--- a/drivers/dma-buf/dma-buf.c
++++ b/drivers/dma-buf/dma-buf.c
+@@ -34,6 +34,7 @@
+ #include <linux/poll.h>
+ #include <linux/reservation.h>
+ #include <linux/mm.h>
++#include <linux/module.h>
+
+ #include <uapi/linux/dma-buf.h>
+
+@@ -974,4 +975,5 @@ static void __exit dma_buf_deinit(void)
+ {
+ dma_buf_uninit_debugfs();
+ }
+-__exitcall(dma_buf_deinit);
++module_exit(dma_buf_deinit);
++MODULE_LICENSE("GPL");
+--- a/kernel/sched/core.c
++++ b/kernel/sched/core.c
+@@ -2170,6 +2170,7 @@ int wake_up_state(struct task_struct *p,
+ {
+ return try_to_wake_up(p, state, 0);
+ }
++EXPORT_SYMBOL_GPL(wake_up_state);
+
+ /*
+ * This function clears the sched_dl_entity static params.