aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.9/206-mips-disable-vdso.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-4.9/206-mips-disable-vdso.patch')
-rw-r--r--target/linux/generic/patches-4.9/206-mips-disable-vdso.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.9/206-mips-disable-vdso.patch b/target/linux/generic/patches-4.9/206-mips-disable-vdso.patch
new file mode 100644
index 0000000000..e45e734cd3
--- /dev/null
+++ b/target/linux/generic/patches-4.9/206-mips-disable-vdso.patch
@@ -0,0 +1,18 @@
+Disable MIPS VDSO until the cache issues have been sorted out.
+
+Signed-off-by: Felix Fietkau <nbd@nbd.name>
+
+--- a/arch/mips/vdso/Makefile
++++ b/arch/mips/vdso/Makefile
+@@ -28,9 +28,9 @@ aflags-vdso := $(ccflags-vdso) \
+ ifndef CONFIG_CPU_MIPSR6
+ ifeq ($(call ld-ifversion, -lt, 225000000, y),y)
+ $(warning MIPS VDSO requires binutils >= 2.25)
+- obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
+- ccflags-vdso += -DDISABLE_MIPS_VDSO
+ endif
++ obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
++ ccflags-vdso += -DDISABLE_MIPS_VDSO
+ endif
+
+ # VDSO linker flags.