aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.9/259-regmap_dynamic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.9/259-regmap_dynamic.patch')
-rw-r--r--target/linux/generic/patches-3.9/259-regmap_dynamic.patch72
1 files changed, 0 insertions, 72 deletions
diff --git a/target/linux/generic/patches-3.9/259-regmap_dynamic.patch b/target/linux/generic/patches-3.9/259-regmap_dynamic.patch
deleted file mode 100644
index 191e5ea1d2..0000000000
--- a/target/linux/generic/patches-3.9/259-regmap_dynamic.patch
+++ /dev/null
@@ -1,72 +0,0 @@
---- a/drivers/base/regmap/Kconfig
-+++ b/drivers/base/regmap/Kconfig
-@@ -3,20 +3,24 @@
- # subsystems should select the appropriate symbols.
-
- config REGMAP
-- default y if (REGMAP_I2C || REGMAP_SPI || REGMAP_MMIO || REGMAP_IRQ)
- select LZO_COMPRESS
- select LZO_DECOMPRESS
- select IRQ_DOMAIN if REGMAP_IRQ
-- bool
-+ tristate "Regmap"
-
- config REGMAP_I2C
-- tristate
-+ select REGMAP
-+ tristate "Regmap I2C"
-
- config REGMAP_SPI
-- tristate
-+ select REGMAP
-+ depends on SPI_MASTER
-+ tristate "Regmap SPI"
-
- config REGMAP_MMIO
-+ select REGMAP
- tristate
-
- config REGMAP_IRQ
-+ select REGMAP
- bool
---- a/include/linux/regmap.h
-+++ b/include/linux/regmap.h
-@@ -45,7 +45,7 @@ struct reg_default {
- unsigned int def;
- };
-
--#ifdef CONFIG_REGMAP
-+#if IS_ENABLED(CONFIG_REGMAP)
-
- enum regmap_endian {
- /* Unspecified -> 0 -> Backwards compatible default */
---- a/drivers/base/regmap/Makefile
-+++ b/drivers/base/regmap/Makefile
-@@ -1,6 +1,8 @@
--obj-$(CONFIG_REGMAP) += regmap.o regcache.o
--obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o regcache-flat.o
--obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
-+regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o regcache-flat.o
-+ifdef CONFIG_DEBUG_FS
-+regmap-core-objs += regmap-debugfs.o
-+endif
-+obj-$(CONFIG_REGMAP) += regmap-core.o
- obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
- obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o
- obj-$(CONFIG_REGMAP_MMIO) += regmap-mmio.o
---- a/drivers/base/regmap/regmap.c
-+++ b/drivers/base/regmap/regmap.c
-@@ -13,6 +13,7 @@
- #include <linux/device.h>
- #include <linux/slab.h>
- #include <linux/export.h>
-+#include <linux/module.h>
- #include <linux/mutex.h>
- #include <linux/err.h>
- #include <linux/rbtree.h>
-@@ -1779,3 +1780,5 @@ static int __init regmap_initcall(void)
- return 0;
- }
- postcore_initcall(regmap_initcall);
-+
-+MODULE_LICENSE("GPL");