aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.14')
-rw-r--r--target/linux/generic/patches-3.14/728-phy-micrel.patch24
-rw-r--r--target/linux/generic/patches-3.14/728-phy-rtl8367b.patch (renamed from target/linux/generic/patches-3.14/729-phy-rtl8367b.patch)4
-rw-r--r--target/linux/generic/patches-3.14/729-phy-tantos.patch6
-rw-r--r--target/linux/generic/patches-3.14/730-phy_b53.patch6
4 files changed, 8 insertions, 32 deletions
diff --git a/target/linux/generic/patches-3.14/728-phy-micrel.patch b/target/linux/generic/patches-3.14/728-phy-micrel.patch
deleted file mode 100644
index baf5a4a7fd..0000000000
--- a/target/linux/generic/patches-3.14/728-phy-micrel.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -144,6 +144,11 @@ config RTL8306_PHY
- tristate "Driver for Realtek RTL8306S switches"
- select SWCONFIG
-
-+config MICREL_PHY
-+ tristate "Drivers for Micrel/Kendin PHYs"
-+ ---help---
-+ Currently has a driver for the KSZ8041
-+
- config FIXED_PHY
- bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
- depends on PHYLIB=y
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -28,6 +28,7 @@ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
- obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
- obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
- obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
-+obj-$(CONFIG_MICREL_PHY) += micrel.o
- obj-$(CONFIG_FIXED_PHY) += fixed.o
- obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
- obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o
diff --git a/target/linux/generic/patches-3.14/729-phy-rtl8367b.patch b/target/linux/generic/patches-3.14/728-phy-rtl8367b.patch
index d69fc89e47..36a82311fe 100644
--- a/target/linux/generic/patches-3.14/729-phy-rtl8367b.patch
+++ b/target/linux/generic/patches-3.14/728-phy-rtl8367b.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -262,6 +262,10 @@ config RTL8367_PHY
+@@ -257,6 +257,10 @@ config RTL8367_PHY
tristate "Driver for the Realtek RTL8367R/M switches"
select SWCONFIG
@@ -19,5 +19,5 @@
obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_MICREL_PHY) += micrel.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
diff --git a/target/linux/generic/patches-3.14/729-phy-tantos.patch b/target/linux/generic/patches-3.14/729-phy-tantos.patch
index 4a9fe873a7..935193a58e 100644
--- a/target/linux/generic/patches-3.14/729-phy-tantos.patch
+++ b/target/linux/generic/patches-3.14/729-phy-tantos.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -273,3 +273,8 @@ endif # PHYLIB
+@@ -268,3 +268,8 @@ endif # PHYLIB
config MICREL_KS8995MA
tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
depends on SPI
@@ -11,10 +11,10 @@
+ select ETHERNET_PACKET_MANGLE
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -30,6 +30,7 @@ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+@@ -29,6 +29,7 @@ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_MICREL_PHY) += micrel.o
+obj-$(CONFIG_PSB6970_PHY) += psb6970.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
diff --git a/target/linux/generic/patches-3.14/730-phy_b53.patch b/target/linux/generic/patches-3.14/730-phy_b53.patch
index cd58182f7e..27b8197e15 100644
--- a/target/linux/generic/patches-3.14/730-phy_b53.patch
+++ b/target/linux/generic/patches-3.14/730-phy_b53.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -268,6 +268,8 @@ config RTL8367B_PHY
+@@ -263,6 +263,8 @@ config RTL8367B_PHY
endif # RTL8366_SMI
@@ -11,9 +11,9 @@
config MICREL_KS8995MA
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -31,6 +31,7 @@ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+@@ -30,6 +30,7 @@ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_MICREL_PHY) += micrel.o
obj-$(CONFIG_PSB6970_PHY) += psb6970.o
+obj-$(CONFIG_B53) += b53/
obj-$(CONFIG_FIXED_PHY) += fixed.o