aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch')
-rw-r--r--target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch b/target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch
new file mode 100644
index 0000000000..eac31d7420
--- /dev/null
+++ b/target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch
@@ -0,0 +1,24 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -37,6 +37,8 @@ config MTD_UIMAGE_SPLIT
+ depends on MTD_SPLIT_FIRMWARE
+ default y
+
++source "drivers/mtd/mtdsplit/Kconfig"
++
+ config MTD_SPLIT
+ def_bool n
+ help
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -7,6 +7,10 @@ obj-$(CONFIG_MTD) += mtd.o
+ mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
+
+ mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
++mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
++mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
++mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
++mtd-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsplit_lzma.o
+
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o