aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.39/833-gpio_buttons.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-2.6.39/833-gpio_buttons.patch')
-rw-r--r--target/linux/generic/patches-2.6.39/833-gpio_buttons.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/target/linux/generic/patches-2.6.39/833-gpio_buttons.patch b/target/linux/generic/patches-2.6.39/833-gpio_buttons.patch
deleted file mode 100644
index cfe00286d9..0000000000
--- a/target/linux/generic/patches-2.6.39/833-gpio_buttons.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/drivers/input/misc/Kconfig
-+++ b/drivers/input/misc/Kconfig
-@@ -467,4 +467,20 @@ config INPUT_XEN_KBDDEV_FRONTEND
- To compile this driver as a module, choose M here: the
- module will be called xen-kbdfront.
-
-+config INPUT_GPIO_BUTTONS
-+ tristate "Polled GPIO buttons interface"
-+ depends on GENERIC_GPIO
-+ select INPUT_POLLDEV
-+ help
-+ This driver implements support for buttons connected
-+ to GPIO pins of various CPUs (and some other chips).
-+
-+ Say Y here if your device has buttons connected
-+ directly to such GPIO pins. Your board-specific
-+ setup logic must also provide a platform device,
-+ with configuration data saying which GPIOs are used.
-+
-+ To compile this driver as a module, choose M here: the
-+ module will be called gpio-buttons.
-+
- endif
---- a/drivers/input/misc/Makefile
-+++ b/drivers/input/misc/Makefile
-@@ -44,4 +44,5 @@ obj-$(CONFIG_INPUT_WISTRON_BTNS) += wist
- obj-$(CONFIG_INPUT_WM831X_ON) += wm831x-on.o
- obj-$(CONFIG_INPUT_XEN_KBDDEV_FRONTEND) += xen-kbdfront.o
- obj-$(CONFIG_INPUT_YEALINK) += yealink.o
-+obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o
-