aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.32/208-mips_oprofile_fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-2.6.32/208-mips_oprofile_fix.patch')
-rw-r--r--target/linux/generic/patches-2.6.32/208-mips_oprofile_fix.patch47
1 files changed, 0 insertions, 47 deletions
diff --git a/target/linux/generic/patches-2.6.32/208-mips_oprofile_fix.patch b/target/linux/generic/patches-2.6.32/208-mips_oprofile_fix.patch
deleted file mode 100644
index 2e019dba2c..0000000000
--- a/target/linux/generic/patches-2.6.32/208-mips_oprofile_fix.patch
+++ /dev/null
@@ -1,47 +0,0 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -48,7 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
- endif
- endif
-
-+ifndef CONFIG_PROFILING
- cflags-y := -ffunction-sections
-+endif
- cflags-y += $(call cc-option, -mno-check-zero-division)
-
- ifdef CONFIG_32BIT
---- a/arch/mips/oprofile/op_model_mipsxx.c
-+++ b/arch/mips/oprofile/op_model_mipsxx.c
-@@ -298,6 +298,11 @@ static void reset_counters(void *arg)
- }
- }
-
-+static irqreturn_t mipsxx_perfcount_int(int irq, void *dev_id)
-+{
-+ return mipsxx_perfcount_handler();
-+}
-+
- static int __init mipsxx_init(void)
- {
- int counters;
-@@ -374,6 +379,10 @@ static int __init mipsxx_init(void)
- save_perf_irq = perf_irq;
- perf_irq = mipsxx_perfcount_handler;
-
-+ if (cp0_perfcount_irq >= 0)
-+ return request_irq(cp0_perfcount_irq, mipsxx_perfcount_int,
-+ IRQF_SHARED, "Perfcounter", save_perf_irq);
-+
- return 0;
- }
-
-@@ -381,6 +390,9 @@ static void mipsxx_exit(void)
- {
- int counters = op_model_mipsxx_ops.num_counters;
-
-+ if (cp0_perfcount_irq >= 0)
-+ free_irq(cp0_perfcount_irq, save_perf_irq);
-+
- counters = counters_per_cpu_to_total(counters);
- on_each_cpu(reset_counters, (void *)(long)counters, 1);
-