aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.30/025-mips_disable_fpu.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.30/025-mips_disable_fpu.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/025-mips_disable_fpu.patch42
1 files changed, 16 insertions, 26 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.30/025-mips_disable_fpu.patch b/target/linux/generic-2.6/patches-2.6.30/025-mips_disable_fpu.patch
index eb6c6e13d8..a8ffc230d7 100644
--- a/target/linux/generic-2.6/patches-2.6.30/025-mips_disable_fpu.patch
+++ b/target/linux/generic-2.6/patches-2.6.30/025-mips_disable_fpu.patch
@@ -6,11 +6,9 @@ precious blocks on an embedded system.
Signed-off-by: Florian Fainelli <florian@openwrt.org>
--
-Index: linux-2.6.30.7/arch/mips/Kconfig
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/Kconfig 2009-09-28 08:21:26.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/Kconfig 2009-09-28 08:21:31.000000000 +0200
-@@ -791,6 +791,17 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -791,6 +791,17 @@ config I8259
config MIPS_BONITO64
bool
@@ -28,10 +26,8 @@ Index: linux-2.6.30.7/arch/mips/Kconfig
config MIPS_MSC
bool
-Index: linux-2.6.30.7/arch/mips/math-emu/Makefile
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/math-emu/Makefile 2009-09-28 08:21:26.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/math-emu/Makefile 2009-09-28 08:21:31.000000000 +0200
+--- a/arch/mips/math-emu/Makefile
++++ b/arch/mips/math-emu/Makefile
@@ -2,12 +2,14 @@
# Makefile for the Linux/MIPS kernel FPU emulation.
#
@@ -49,10 +45,8 @@ Index: linux-2.6.30.7/arch/mips/math-emu/Makefile
+ dp_sqrt.o sp_sqrt.o
EXTRA_CFLAGS += -Werror
-Index: linux-2.6.30.7/arch/mips/math-emu/cp1emu.c
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/math-emu/cp1emu.c 2009-09-28 08:21:26.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/math-emu/cp1emu.c 2009-09-28 08:21:31.000000000 +0200
+--- a/arch/mips/math-emu/cp1emu.c
++++ b/arch/mips/math-emu/cp1emu.c
@@ -56,6 +56,12 @@
#endif
#define __mips 4
@@ -66,7 +60,7 @@ Index: linux-2.6.30.7/arch/mips/math-emu/cp1emu.c
/* Function which emulates a floating point instruction. */
static int fpu_emu(struct pt_regs *, struct mips_fpu_struct *,
-@@ -66,10 +72,6 @@
+@@ -66,10 +72,6 @@ static int fpux_emu(struct pt_regs *,
struct mips_fpu_struct *, mips_instruction);
#endif
@@ -77,7 +71,7 @@ Index: linux-2.6.30.7/arch/mips/math-emu/cp1emu.c
/* Control registers */
#define FPCREG_RID 0 /* $0 = revision id */
-@@ -1273,6 +1275,13 @@
+@@ -1273,6 +1275,13 @@ int fpu_emulator_cop1Handler(struct pt_r
return sig;
}
@@ -91,11 +85,9 @@ Index: linux-2.6.30.7/arch/mips/math-emu/cp1emu.c
#ifdef CONFIG_DEBUG_FS
extern struct dentry *mips_debugfs_dir;
-Index: linux-2.6.30.7/arch/mips/math-emu/dsemul.c
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/math-emu/dsemul.c 2009-09-28 08:21:26.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/math-emu/dsemul.c 2009-09-28 08:21:31.000000000 +0200
-@@ -109,6 +109,7 @@
+--- a/arch/mips/math-emu/dsemul.c
++++ b/arch/mips/math-emu/dsemul.c
+@@ -109,6 +109,7 @@ int mips_dsemul(struct pt_regs *regs, mi
return SIGILL; /* force out of emulation loop */
}
@@ -103,7 +95,7 @@ Index: linux-2.6.30.7/arch/mips/math-emu/dsemul.c
int do_dsemulret(struct pt_regs *xcp)
{
struct emuframe __user *fr;
-@@ -165,3 +166,9 @@
+@@ -165,3 +166,9 @@ int do_dsemulret(struct pt_regs *xcp)
return 1;
}
@@ -113,10 +105,8 @@ Index: linux-2.6.30.7/arch/mips/math-emu/dsemul.c
+ return 0;
+}
+#endif /* CONFIG_MIPS_FPU_EMU */
-Index: linux-2.6.30.7/arch/mips/math-emu/kernel_linkage.c
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/math-emu/kernel_linkage.c 2009-09-28 08:21:26.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/math-emu/kernel_linkage.c 2009-09-28 08:22:36.000000000 +0200
+--- a/arch/mips/math-emu/kernel_linkage.c
++++ b/arch/mips/math-emu/kernel_linkage.c
@@ -29,6 +29,7 @@
#define SIGNALLING_NAN 0x7ff800007ff80000LL
@@ -125,7 +115,7 @@ Index: linux-2.6.30.7/arch/mips/math-emu/kernel_linkage.c
void fpu_emulator_init_fpu(void)
{
static int first = 1;
-@@ -112,4 +113,36 @@
+@@ -112,4 +113,36 @@ int fpu_emulator_restore_context32(struc
return err;
}