aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.28/921-gpio_spi_driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.28/921-gpio_spi_driver.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/921-gpio_spi_driver.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.28/921-gpio_spi_driver.patch b/target/linux/generic-2.6/patches-2.6.28/921-gpio_spi_driver.patch
index eb9155c8d7..9e68770fbb 100644
--- a/target/linux/generic-2.6/patches-2.6.28/921-gpio_spi_driver.patch
+++ b/target/linux/generic-2.6/patches-2.6.28/921-gpio_spi_driver.patch
@@ -9,7 +9,7 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
Index: linux-2.6.28.2/include/linux/spi/spi_gpio_old.h
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.28.2/include/linux/spi/spi_gpio_old.h 2009-02-10 17:14:33.000000000 +0100
++++ linux-2.6.28.2/include/linux/spi/spi_gpio_old.h 2009-02-10 17:59:21.000000000 +0100
@@ -0,0 +1,73 @@
+/*
+ * spi_gpio interface to platform code
@@ -87,7 +87,7 @@ Index: linux-2.6.28.2/include/linux/spi/spi_gpio_old.h
Index: linux-2.6.28.2/drivers/spi/spi_gpio_old.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.28.2/drivers/spi/spi_gpio_old.c 2009-02-10 17:15:01.000000000 +0100
++++ linux-2.6.28.2/drivers/spi/spi_gpio_old.c 2009-02-10 17:59:21.000000000 +0100
@@ -0,0 +1,251 @@
+/*
+ * Bitbanging SPI bus driver using GPIO API
@@ -342,11 +342,11 @@ Index: linux-2.6.28.2/drivers/spi/spi_gpio_old.c
+MODULE_LICENSE("GPL v2");
Index: linux-2.6.28.2/drivers/spi/Kconfig
===================================================================
---- linux-2.6.28.2.orig/drivers/spi/Kconfig 2009-02-10 17:13:57.000000000 +0100
-+++ linux-2.6.28.2/drivers/spi/Kconfig 2009-02-10 17:14:33.000000000 +0100
-@@ -100,6 +100,15 @@ config SPI_BUTTERFLY
- inexpensive battery powered microcontroller evaluation board.
- This same cable can be used to flash new firmware.
+--- linux-2.6.28.2.orig/drivers/spi/Kconfig 2009-02-10 17:58:37.000000000 +0100
++++ linux-2.6.28.2/drivers/spi/Kconfig 2009-02-10 17:59:21.000000000 +0100
+@@ -116,6 +116,15 @@ config SPI_GPIO
+ GPIO operations, you should be able to leverage that for better
+ speed with a custom version of this driver; see the source code.
+config SPI_GPIO_OLD
+ tristate "Old GPIO API based bitbanging SPI controller (DEPRECATED)"
@@ -362,12 +362,12 @@ Index: linux-2.6.28.2/drivers/spi/Kconfig
depends on ARCH_IMX && EXPERIMENTAL
Index: linux-2.6.28.2/drivers/spi/Makefile
===================================================================
---- linux-2.6.28.2.orig/drivers/spi/Makefile 2009-02-10 17:13:57.000000000 +0100
-+++ linux-2.6.28.2/drivers/spi/Makefile 2009-02-10 17:14:33.000000000 +0100
-@@ -16,6 +16,7 @@ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.
- obj-$(CONFIG_SPI_BITBANG) += spi_bitbang.o
+--- linux-2.6.28.2.orig/drivers/spi/Makefile 2009-02-10 17:59:04.000000000 +0100
++++ linux-2.6.28.2/drivers/spi/Makefile 2009-02-10 17:59:51.000000000 +0100
+@@ -17,6 +17,7 @@ obj-$(CONFIG_SPI_BITBANG) += spi_bitban
obj-$(CONFIG_SPI_AU1550) += au1550_spi.o
obj-$(CONFIG_SPI_BUTTERFLY) += spi_butterfly.o
+ obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
+obj-$(CONFIG_SPI_GPIO_OLD) += spi_gpio_old.o
obj-$(CONFIG_SPI_IMX) += spi_imx.o
obj-$(CONFIG_SPI_LM70_LLP) += spi_lm70llp.o