aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch b/target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch
index 52c89d80f2..2e5b9e813a 100644
--- a/target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch
+++ b/target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.22.4/net/netfilter/Kconfig
+Index: linux-2.6.22.18/net/netfilter/Kconfig
===================================================================
---- linux-2.6.22.4.orig/net/netfilter/Kconfig
-+++ linux-2.6.22.4/net/netfilter/Kconfig
+--- linux-2.6.22.18.orig/net/netfilter/Kconfig
++++ linux-2.6.22.18/net/netfilter/Kconfig
@@ -379,6 +379,23 @@ config NETFILTER_XT_TARGET_CONNSECMARK
To compile it as a module, choose M here. If unsure, say N.
@@ -26,22 +26,22 @@ Index: linux-2.6.22.4/net/netfilter/Kconfig
config NETFILTER_XT_TARGET_TCPMSS
tristate '"TCPMSS" target support'
depends on NETFILTER_XTABLES && (IPV6 || IPV6=n)
-Index: linux-2.6.22.4/net/netfilter/Makefile
+Index: linux-2.6.22.18/net/netfilter/Makefile
===================================================================
---- linux-2.6.22.4.orig/net/netfilter/Makefile
-+++ linux-2.6.22.4/net/netfilter/Makefile
-@@ -47,6 +47,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFQUEUE
+--- linux-2.6.22.18.orig/net/netfilter/Makefile
++++ linux-2.6.22.18/net/netfilter/Makefile
+@@ -45,6 +45,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFQUEUE
obj-$(CONFIG_NETFILTER_XT_TARGET_NFLOG) += xt_NFLOG.o
obj-$(CONFIG_NETFILTER_XT_TARGET_NOTRACK) += xt_NOTRACK.o
obj-$(CONFIG_NETFILTER_XT_TARGET_SECMARK) += xt_SECMARK.o
+obj-$(CONFIG_NETFILTER_XT_TARGET_TARPIT) += xt_TARPIT.o
obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
obj-$(CONFIG_NETFILTER_XT_TARGET_CONNSECMARK) += xt_CONNSECMARK.o
-
-Index: linux-2.6.22.4/net/netfilter/xt_TARPIT.c
+ obj-$(CONFIG_NETFILTER_XT_TARGET_CHAOS) += xt_CHAOS.o
+Index: linux-2.6.22.18/net/netfilter/xt_TARPIT.c
===================================================================
--- /dev/null
-+++ linux-2.6.22.4/net/netfilter/xt_TARPIT.c
++++ linux-2.6.22.18/net/netfilter/xt_TARPIT.c
@@ -0,0 +1,280 @@
+/*
+ * Kernel module to capture and hold incoming TCP connections using
@@ -284,7 +284,7 @@ Index: linux-2.6.22.4/net/netfilter/xt_TARPIT.c
+ return NF_DROP;
+}
+
-+static bool xt_tarpit_check(const char *tablename, const void *entry,
++static int xt_tarpit_check(const char *tablename, const void *entry,
+ const struct xt_target *target, void *targinfo,
+ unsigned int hook_mask)
+{