aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/gemini/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/gemini/Makefile')
-rw-r--r--target/linux/gemini/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/target/linux/gemini/Makefile b/target/linux/gemini/Makefile
index f02e4b179f..a9414a2606 100644
--- a/target/linux/gemini/Makefile
+++ b/target/linux/gemini/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009-2013 OpenWrt.org
+# Copyright (C) 2009-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,14 +9,17 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=gemini
BOARDNAME:=Cortina Systems CS351x
-SUBTARGETS:=raidsonic wiligear
-FEATURES:=squashfs pci rtc
+FEATURES:=squashfs pci rtc usb dt gpio
CPU_TYPE:=fa526
MAINTAINER:=Roman Yeryomin <roman@advem.lv>
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=4.14
-KERNELNAME:=zImage
+define Target/Description
+ Build firmware images for the StorLink/Cortina Gemini CS351x ARM FA526 CPU
+endef
+
+KERNELNAME:=zImage dtbs
include $(INCLUDE_DIR)/target.mk