aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ep93xx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ep93xx/Makefile')
-rw-r--r--target/linux/ep93xx/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ep93xx/Makefile b/target/linux/ep93xx/Makefile
new file mode 100644
index 0000000000..a43855ed18
--- /dev/null
+++ b/target/linux/ep93xx/Makefile
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=ep93xx
+BOARDNAME:=Cirrus Logic EP93xx SoC
+FEATURES:=squashfs jffs2 ext2 tgz
+CFLAGS:=-Os -pipe -march=armv4t -funit-at-a-time
+
+LINUX_VERSION:=2.6.30.9
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="uImage"
+
+$(eval $(call BuildTarget))