aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns21xx/patches-2.6.36/003-arm-introduce-fa-platform.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/cns21xx/patches-2.6.36/003-arm-introduce-fa-platform.patch')
-rw-r--r--target/linux/cns21xx/patches-2.6.36/003-arm-introduce-fa-platform.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/target/linux/cns21xx/patches-2.6.36/003-arm-introduce-fa-platform.patch b/target/linux/cns21xx/patches-2.6.36/003-arm-introduce-fa-platform.patch
new file mode 100644
index 0000000000..811d115af8
--- /dev/null
+++ b/target/linux/cns21xx/patches-2.6.36/003-arm-introduce-fa-platform.patch
@@ -0,0 +1,47 @@
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -954,10 +954,15 @@ source "arch/arm/mach-vexpress/Kconfig"
+
+ source "arch/arm/mach-w90x900/Kconfig"
+
++source "arch/arm/plat-fa/Kconfig"
++
+ # Definitions to make life easier
+ config ARCH_ACORN
+ bool
+
++config PLAT_FA
++ bool
++
+ config PLAT_IOP
+ bool
+ select GENERIC_CLOCKEVENTS
+--- a/arch/arm/Makefile
++++ b/arch/arm/Makefile
+@@ -202,6 +202,7 @@ plat-$(CONFIG_ARCH_MXC) := mxc
+ plat-$(CONFIG_ARCH_OMAP) := omap
+ plat-$(CONFIG_ARCH_S3C64XX) := samsung
+ plat-$(CONFIG_ARCH_STMP3XXX) := stmp3xxx
++plat-$(CONFIG_PLAT_FA) := fa
+ plat-$(CONFIG_PLAT_IOP) := iop
+ plat-$(CONFIG_PLAT_NOMADIK) := nomadik
+ plat-$(CONFIG_PLAT_ORION) := orion
+--- /dev/null
++++ b/arch/arm/plat-fa/Makefile
+@@ -0,0 +1,10 @@
++#
++# Makefile for the linux kernel.
++#
++
++obj-y :=
++
++obj-m :=
++obj-n :=
++obj- :=
++
+--- /dev/null
++++ b/arch/arm/plat-fa/Kconfig
+@@ -0,0 +1,3 @@
++if PLAT_FA
++
++endif