aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/image/bcm63xx.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/brcm63xx/image/bcm63xx.mk b/target/linux/brcm63xx/image/bcm63xx.mk
index 34d496e928..ce03f7b700 100644
--- a/target/linux/brcm63xx/image/bcm63xx.mk
+++ b/target/linux/brcm63xx/image/bcm63xx.mk
@@ -922,7 +922,7 @@ define Device/NEUFBOX4-SER
DEVICE_DTS := nb4-ser-r0
CFE_BOARD_ID := 96358VW
CFE_CHIP_ID := 6358
- CFE_EXTRAS += --rsa-signature "LEDE-$(REVISION)"
+ CFE_EXTRAS += --rsa-signature "LEDE-$(firstword $(subst -,$(space),$(REVISION)))"
DEVICE_PACKAGES := \
$(B43_PACKAGES) $(USB2_PACKAGES)
endef
@@ -934,7 +934,7 @@ define Device/NEUFBOX4-FXC
DEVICE_DTS := nb4-fxc-r1
CFE_BOARD_ID := 96358VW
CFE_CHIP_ID := 6358
- CFE_EXTRAS += --rsa-signature "LEDE-$(REVISION)"
+ CFE_EXTRAS += --rsa-signature "LEDE-$(firstword $(subst -,$(space),$(REVISION)))"
DEVICE_PACKAGES := \
$(B43_PACKAGES) $(USB2_PACKAGES)
endef
@@ -946,7 +946,7 @@ define Device/NEUFBOX6
DEVICE_DTS := nb6-ser-r0
CFE_BOARD_ID := NB6-SER-r0
CFE_CHIP_ID := 6362
- CFE_EXTRAS += --rsa-signature "LEDE-$(REVISION)"
+ CFE_EXTRAS += --rsa-signature "LEDE-$(firstword $(subst -,$(space),$(REVISION)))"
DEVICE_PACKAGES := \
$(B43_PACKAGES) $(USB2_PACKAGES)
endef