aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/patches-4.9/391-MIPS-BCM63XX-do-not-register-uart.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm63xx/patches-4.9/391-MIPS-BCM63XX-do-not-register-uart.patch')
-rw-r--r--target/linux/brcm63xx/patches-4.9/391-MIPS-BCM63XX-do-not-register-uart.patch32
1 files changed, 16 insertions, 16 deletions
diff --git a/target/linux/brcm63xx/patches-4.9/391-MIPS-BCM63XX-do-not-register-uart.patch b/target/linux/brcm63xx/patches-4.9/391-MIPS-BCM63XX-do-not-register-uart.patch
index e033ea3a4b..9bf1f45ce4 100644
--- a/target/linux/brcm63xx/patches-4.9/391-MIPS-BCM63XX-do-not-register-uart.patch
+++ b/target/linux/brcm63xx/patches-4.9/391-MIPS-BCM63XX-do-not-register-uart.patch
@@ -2,11 +2,11 @@
+++ b/arch/mips/bcm63xx/Makefile
@@ -1,6 +1,6 @@
obj-y += clk.o cpu.o cs.o gpio.o irq.o nvram.o prom.o reset.o \
- setup.o timer.o dev-dsp.o dev-enet.o dev-flash.o \
-- dev-pcmcia.o dev-rng.o dev-uart.o \
-+ dev-pcmcia.o dev-rng.o \
- dev-wdt.o dev-usb-ehci.o dev-usb-ohci.o dev-usb-usbd.o \
- usb-common.o sprom.o
+ setup.o timer.o dev-enet.o dev-flash.o dev-pcmcia.o \
+- dev-rng.o dev-uart.o dev-wdt.o \
++ dev-rng.o dev-wdt.o \
+ dev-usb-ehci.o dev-usb-ohci.o dev-usb-usbd.o usb-common.o \
+ sprom.o
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
--- a/arch/mips/bcm63xx/dev-uart.c
+++ /dev/null
@@ -98,10 +98,10 @@
-#endif /* BCM63XX_DEV_UART_H_ */
--- a/arch/mips/include/asm/mach-bcm63xx/board_bcm963xx.h
+++ b/arch/mips/include/asm/mach-bcm63xx/board_bcm963xx.h
-@@ -33,8 +33,6 @@ struct board_info {
+@@ -31,8 +31,6 @@ struct board_info {
+ unsigned int has_ohci0:1;
unsigned int has_ehci0:1;
unsigned int has_usbd:1;
- unsigned int has_dsp:1;
- unsigned int has_uart0:1;
- unsigned int has_uart1:1;
unsigned int use_fallback_sprom:1;
@@ -117,7 +117,7 @@
#include <bcm63xx_regs.h>
#include <bcm63xx_io.h>
#include <bcm63xx_gpio.h>
-@@ -189,12 +188,6 @@ int __init board_register_devices(void)
+@@ -188,12 +187,6 @@ int __init board_register_devices(void)
bcm63xx_gpio_init();
@@ -191,7 +191,7 @@
.has_enet0 = 1,
.has_enet1 = 1,
.has_pci = 1,
-@@ -323,7 +313,6 @@ static struct board_info __initdata boar
+@@ -315,7 +305,6 @@ static struct board_info __initdata boar
.name = "96348GW-11",
.expected_cpu_id = 0x6348,
@@ -199,7 +199,7 @@
.has_enet0 = 1,
.has_enet1 = 1,
.has_pci = 1,
-@@ -378,7 +367,6 @@ static struct board_info __initdata boar
+@@ -370,7 +359,6 @@ static struct board_info __initdata boar
.name = "96348GW",
.expected_cpu_id = 0x6348,
@@ -207,7 +207,7 @@
.has_enet0 = 1,
.has_enet1 = 1,
.has_pci = 1,
-@@ -437,7 +425,6 @@ static struct board_info __initdata boar
+@@ -421,7 +409,6 @@ static struct board_info __initdata boar
.name = "F@ST2404",
.expected_cpu_id = 0x6348,
@@ -215,7 +215,7 @@
.has_enet0 = 1,
.has_enet1 = 1,
.has_pci = 1,
-@@ -482,7 +469,6 @@ static struct board_info __initdata boar
+@@ -466,7 +453,6 @@ static struct board_info __initdata boar
.name = "DV201AMR",
.expected_cpu_id = 0x6348,
@@ -223,7 +223,7 @@
.has_pci = 1,
.use_fallback_sprom = 1,
.has_ohci0 = 1,
-@@ -503,7 +489,6 @@ static struct board_info __initdata boar
+@@ -487,7 +473,6 @@ static struct board_info __initdata boar
.name = "96348GW-A",
.expected_cpu_id = 0x6348,
@@ -231,7 +231,7 @@
.has_enet0 = 1,
.has_enet1 = 1,
.has_pci = 1,
-@@ -530,7 +515,6 @@ static struct board_info __initdata boar
+@@ -514,7 +499,6 @@ static struct board_info __initdata boar
.name = "96358VW",
.expected_cpu_id = 0x6358,
@@ -239,7 +239,7 @@
.has_enet0 = 1,
.has_enet1 = 1,
.has_pci = 1,
-@@ -583,7 +567,6 @@ static struct board_info __initdata boar
+@@ -567,7 +551,6 @@ static struct board_info __initdata boar
.name = "96358VW2",
.expected_cpu_id = 0x6358,
@@ -247,7 +247,7 @@
.has_enet0 = 1,
.has_enet1 = 1,
.has_pci = 1,
-@@ -633,7 +616,6 @@ static struct board_info __initdata boar
+@@ -617,7 +600,6 @@ static struct board_info __initdata boar
.name = "AGPF-S0",
.expected_cpu_id = 0x6358,