aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image/bcm63xx.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm63xx/image/bcm63xx.mk')
-rw-r--r--target/linux/brcm63xx/image/bcm63xx.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/bcm63xx.mk b/target/linux/brcm63xx/image/bcm63xx.mk
index 4e90eb0504..918dfc7981 100644
--- a/target/linux/brcm63xx/image/bcm63xx.mk
+++ b/target/linux/brcm63xx/image/bcm63xx.mk
@@ -971,6 +971,18 @@ define Device/FAST2704V2
endef
TARGET_DEVICES += FAST2704V2
+### Sercomm ###
+define Device/AD1018-SPI_flash
+ $(Device/bcm63xx)
+ DEVICE_TITLE := Sercomm AD1018 (SPI flash mod)
+ DEVICE_DTS := ad1018-nor
+ CFE_BOARD_ID := 96328avngr
+ CFE_CHIP_ID := 6328
+ DEVICE_PACKAGES := \
+ $(B43_PACKAGES) $(USB2_PACKAGES)
+endef
+TARGET_DEVICES += AD1018-SPI_flash
+
### SFR ###
define Device/NEUFBOX4-SER
$(Device/bcm63xx)