aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/mips74k
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm47xx/mips74k')
-rw-r--r--target/linux/brcm47xx/mips74k/profiles/100-Broadcom-b43.mk19
-rw-r--r--target/linux/brcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk19
-rw-r--r--target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk19
-rw-r--r--target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk18
-rw-r--r--target/linux/brcm47xx/mips74k/target.mk6
5 files changed, 81 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/mips74k/profiles/100-Broadcom-b43.mk b/target/linux/brcm47xx/mips74k/profiles/100-Broadcom-b43.mk
new file mode 100644
index 0000000000..7d3c6a7a52
--- /dev/null
+++ b/target/linux/brcm47xx/mips74k/profiles/100-Broadcom-b43.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-b43
+ NAME:=Broadcom SoC, BCM43xx WiFi (b43)
+ PACKAGES:=kmod-bgmac kmod-b43
+endef
+
+define Profile/Broadcom-mips74k-b43/Description
+ Package set for devices with BCM43xx WiFi including mac80211 and b43
+ driver.
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-b43))
+
diff --git a/target/linux/brcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk b/target/linux/brcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk
new file mode 100644
index 0000000000..2d09cd2856
--- /dev/null
+++ b/target/linux/brcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-brcmsmac
+ NAME:=Broadcom SoC, BCM43xx WiFi (brcmsmac)
+ PACKAGES:=kmod-bgmac kmod-brcmsmac
+endef
+
+define Profile/Broadcom-mips74k-brcmsmac/Description
+ Package set for devices with BCM43xx WiFi including mac80211 and
+ brcmsmac driver.
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-brcmsmac))
+
diff --git a/target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk b/target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk
new file mode 100644
index 0000000000..37063acaae
--- /dev/null
+++ b/target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-wl
+ NAME:=Broadcom SoC, BCM43xx WiFi (proprietary wl)
+ PACKAGES:=kmod-bgmac -wpad-mini kmod-brcm-wl wlc nas
+endef
+
+define Profile/Broadcom-mips74k-wl/Description
+ Package set for devices with BCM43xx WiFi including proprietary (and
+ closed source) driver "wl".
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-wl))
+
diff --git a/target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk b/target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk
new file mode 100644
index 0000000000..bfe3719247
--- /dev/null
+++ b/target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-none
+ NAME:=Broadcom SoC, No WiFi
+ PACKAGES:=kmod-bgmac -wpad-mini
+endef
+
+define Profile/Broadcom-mips74k-none/Description
+ Package set for devices without a WiFi.
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-none))
+
diff --git a/target/linux/brcm47xx/mips74k/target.mk b/target/linux/brcm47xx/mips74k/target.mk
new file mode 100644
index 0000000000..ab7af28b67
--- /dev/null
+++ b/target/linux/brcm47xx/mips74k/target.mk
@@ -0,0 +1,6 @@
+BOARDNAME:=MIPS 74K
+
+define Target/Description
+ Build firmware for Broadcom BCM47xx and BCM53xx devices with
+ MIPS 74K CPU.
+endef