aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm47xx/image/Makefile')
-rw-r--r--target/linux/brcm47xx/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 7b5e00dee2..0074cf3edd 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -191,6 +191,7 @@ ifeq ($(SUBTARGET),generic)
# BCM4705 with tg3
define Device/linksys-wrt300n-v1.1
DEVICE_TITLE := Linksys WRT300N v1.1
+ DEVICE_PACKAGES := kmod-tg3 kmod-b43
$(Device/linksys)
DEVICE_ID := EWC2
VERSION := 1.51.2
@@ -199,6 +200,7 @@ TARGET_DEVICES += linksys-wrt300n-v1.1
define Device/linksys-wrt310n-v1
DEVICE_TITLE := Linksys WRT310N v1
+ DEVICE_PACKAGES := kmod-tg3 kmod-b43
$(Device/linksys)
DEVICE_ID := 310N
VERSION := 1.0.10
@@ -207,6 +209,7 @@ TARGET_DEVICES += linksys-wrt310n-v1
define Device/linksys-wrt350n-v1
DEVICE_TITLE := Linksys WRT350N v1
+ DEVICE_PACKAGES := kmod-tg3 kmod-b43 $(USB2_PACKAGES)
$(Device/linksys)
DEVICE_ID := EWCG
VERSION := 1.04.1
@@ -215,6 +218,7 @@ TARGET_DEVICES += linksys-wrt350n-v1
define Device/linksys-wrt610n-v1
DEVICE_TITLE := Linksys WRT610N v1
+ DEVICE_PACKAGES := kmod-tg3 kmod-b43 $(USB2_PACKAGES)
$(Device/linksys)
DEVICE_ID := 610N
VERSION := 1.0.1
@@ -224,6 +228,7 @@ TARGET_DEVICES += linksys-wrt610n-v1
# BCMA SoC with SSB WiFi
define Device/linksys-wrt610n-v2
DEVICE_TITLE := Linksys WRT610N v2
+ DEVICE_PACKAGES := kmod-bgmac kmod-b43 $(USB2_PACKAGES)
$(Device/linksys)
DEVICE_ID := 610N
VERSION := 2.0.0
@@ -232,6 +237,7 @@ TARGET_DEVICES += linksys-wrt610n-v2
define Device/linksys-e3000-v1
DEVICE_TITLE := Linksys E3000 v1
+ DEVICE_PACKAGES := kmod-bgmac kmod-b43 $(USB2_PACKAGES)
$(Device/linksys)
DEVICE_ID := 61XN
VERSION := 1.0.3