aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-4.9/950-0192-Add-support-for-Fe-Pi-audio-sound-card.-1867.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/patches-4.9/950-0192-Add-support-for-Fe-Pi-audio-sound-card.-1867.patch')
-rw-r--r--target/linux/brcm2708/patches-4.9/950-0192-Add-support-for-Fe-Pi-audio-sound-card.-1867.patch333
1 files changed, 0 insertions, 333 deletions
diff --git a/target/linux/brcm2708/patches-4.9/950-0192-Add-support-for-Fe-Pi-audio-sound-card.-1867.patch b/target/linux/brcm2708/patches-4.9/950-0192-Add-support-for-Fe-Pi-audio-sound-card.-1867.patch
deleted file mode 100644
index 262dc14bce..0000000000
--- a/target/linux/brcm2708/patches-4.9/950-0192-Add-support-for-Fe-Pi-audio-sound-card.-1867.patch
+++ /dev/null
@@ -1,333 +0,0 @@
-From c646d023c75607a9ebc7296fe424d6eb4e804164 Mon Sep 17 00:00:00 2001
-From: Fe-Pi <fe-pi@cox.net>
-Date: Wed, 1 Mar 2017 04:42:43 -0700
-Subject: [PATCH] Add support for Fe-Pi audio sound card. (#1867)
-
-Fe-Pi Audio Sound Card is based on NXP SGTL5000 codec.
-Mechanical specification of the board is the same the Raspberry Pi Zero.
-3.5mm jacks for Headphone/Mic, Line In, and Line Out.
-
-Signed-off-by: Henry Kupis <fe-pi@cox.net>
----
- arch/arm/boot/dts/overlays/Makefile | 1 +
- arch/arm/boot/dts/overlays/README | 6 +
- arch/arm/boot/dts/overlays/fe-pi-audio-overlay.dts | 70 +++++++++
- arch/arm/configs/bcm2709_defconfig | 1 +
- arch/arm/configs/bcmrpi_defconfig | 1 +
- sound/soc/bcm/Kconfig | 7 +
- sound/soc/bcm/Makefile | 2 +
- sound/soc/bcm/fe-pi-audio.c | 158 +++++++++++++++++++++
- 8 files changed, 246 insertions(+)
- create mode 100644 arch/arm/boot/dts/overlays/fe-pi-audio-overlay.dts
- create mode 100644 sound/soc/bcm/fe-pi-audio.c
-
---- a/arch/arm/boot/dts/overlays/Makefile
-+++ b/arch/arm/boot/dts/overlays/Makefile
-@@ -20,6 +20,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
- dwc2.dtbo \
- enc28j60.dtbo \
- enc28j60-spi2.dtbo \
-+ fe-pi-audio.dtbo \
- gpio-ir.dtbo \
- gpio-poweroff.dtbo \
- hifiberry-amp.dtbo \
---- a/arch/arm/boot/dts/overlays/README
-+++ b/arch/arm/boot/dts/overlays/README
-@@ -383,6 +383,12 @@ Params: int_pin GPIO use
- speed SPI bus speed (default 12000000)
-
-
-+Name: fe-pi-audio
-+Info: Configures the Fe-Pi Audio Sound Card
-+Load: dtoverlay=fe-pi-audio
-+Params: <None>
-+
-+
- Name: gpio-ir
- Info: Use GPIO pin as rc-core style infrared receiver input. The rc-core-
- based gpio_ir_recv driver maps received keys directly to a
---- /dev/null
-+++ b/arch/arm/boot/dts/overlays/fe-pi-audio-overlay.dts
-@@ -0,0 +1,70 @@
-+// Definitions for Fe-Pi Audio
-+/dts-v1/;
-+/plugin/;
-+
-+/ {
-+ compatible = "brcm,bcm2708";
-+
-+ fragment@0 {
-+ target = <&clocks>;
-+ __overlay__ {
-+ sgtl5000_mclk: sgtl5000_mclk {
-+ compatible = "fixed-clock";
-+ #clock-cells = <0>;
-+ clock-frequency = <12288000>;
-+ clock-output-names = "sgtl5000-mclk";
-+ };
-+ };
-+ };
-+
-+ fragment@1 {
-+ target = <&soc>;
-+ __overlay__ {
-+ reg_1v8: reg_1v8@0 {
-+ compatible = "regulator-fixed";
-+ regulator-name = "1V8";
-+ regulator-min-microvolt = <1800000>;
-+ regulator-max-microvolt = <1800000>;
-+ regulator-always-on;
-+ };
-+ };
-+ };
-+
-+ fragment@2 {
-+ target = <&i2c1>;
-+ __overlay__ {
-+ #address-cells = <1>;
-+ #size-cells = <0>;
-+ status = "okay";
-+
-+ sgtl5000@0a {
-+ #sound-dai-cells = <0>;
-+ compatible = "fepi,sgtl5000";
-+ reg = <0x0a>;
-+ clocks = <&sgtl5000_mclk>;
-+ micbias-resistor-k-ohms = <2>;
-+ micbias-voltage-m-volts = <3000>;
-+ VDDA-supply = <&vdd_3v3_reg>;
-+ VDDIO-supply = <&vdd_3v3_reg>;
-+ VDDD-supply = <&reg_1v8>;
-+ status = "okay";
-+ };
-+ };
-+ };
-+
-+ fragment@3 {
-+ target = <&i2s>;
-+ __overlay__ {
-+ status = "okay";
-+ };
-+ };
-+
-+ fragment@4 {
-+ target = <&sound>;
-+ __overlay__ {
-+ compatible = "fe-pi,fe-pi-audio";
-+ i2s-controller = <&i2s>;
-+ status = "okay";
-+ };
-+ };
-+};
---- a/arch/arm/configs/bcm2709_defconfig
-+++ b/arch/arm/configs/bcm2709_defconfig
-@@ -891,6 +891,7 @@ CONFIG_SND_DIGIDAC1_SOUNDCARD=m
- CONFIG_SND_BCM2708_SOC_DIONAUDIO_LOCO=m
- CONFIG_SND_BCM2708_SOC_DIONAUDIO_LOCO_V2=m
- CONFIG_SND_BCM2708_SOC_ALLO_PIANO_DAC=m
-+CONFIG_SND_BCM2708_SOC_FE_PI_AUDIO=m
- CONFIG_SND_PISOUND=m
- CONFIG_SND_SOC_ADAU1701=m
- CONFIG_SND_SOC_ADAU7002=m
---- a/arch/arm/configs/bcmrpi_defconfig
-+++ b/arch/arm/configs/bcmrpi_defconfig
-@@ -885,6 +885,7 @@ CONFIG_SND_DIGIDAC1_SOUNDCARD=m
- CONFIG_SND_BCM2708_SOC_DIONAUDIO_LOCO=m
- CONFIG_SND_BCM2708_SOC_DIONAUDIO_LOCO_V2=m
- CONFIG_SND_BCM2708_SOC_ALLO_PIANO_DAC=m
-+CONFIG_SND_BCM2708_SOC_FE_PI_AUDIO=m
- CONFIG_SND_PISOUND=m
- CONFIG_SND_SOC_ADAU1701=m
- CONFIG_SND_SOC_ADAU7002=m
---- a/sound/soc/bcm/Kconfig
-+++ b/sound/soc/bcm/Kconfig
-@@ -147,6 +147,13 @@ config SND_BCM2708_SOC_ALLO_PIANO_DAC
- help
- Say Y or M if you want to add support for Allo Piano DAC.
-
-+config SND_BCM2708_SOC_FE_PI_AUDIO
-+ tristate "Support for Fe-Pi-Audio"
-+ depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
-+ select SND_SOC_SGTL5000
-+ help
-+ Say Y or M if you want to add support for Fe-Pi-Audio.
-+
- config SND_PISOUND
- tristate "Support for Blokas Labs pisound"
- depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
---- a/sound/soc/bcm/Makefile
-+++ b/sound/soc/bcm/Makefile
-@@ -28,6 +28,7 @@ snd-soc-dionaudio-loco-objs := dionaudio
- snd-soc-dionaudio-loco-v2-objs := dionaudio_loco-v2.o
- snd-soc-allo-piano-dac-objs := allo-piano-dac.o
- snd-soc-pisound-objs := pisound.o
-+snd-soc-fe-pi-audio-objs := fe-pi-audio.o
-
- obj-$(CONFIG_SND_BCM2708_SOC_ADAU1977_ADC) += snd-soc-adau1977-adc.o
- obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_AMP) += snd-soc-hifiberry-amp.o
-@@ -48,3 +49,4 @@ obj-$(CONFIG_SND_BCM2708_SOC_DIONAUDIO_L
- obj-$(CONFIG_SND_BCM2708_SOC_DIONAUDIO_LOCO_V2) += snd-soc-dionaudio-loco-v2.o
- obj-$(CONFIG_SND_BCM2708_SOC_ALLO_PIANO_DAC) += snd-soc-allo-piano-dac.o
- obj-$(CONFIG_SND_PISOUND) += snd-soc-pisound.o
-+obj-$(CONFIG_SND_BCM2708_SOC_FE_PI_AUDIO) += snd-soc-fe-pi-audio.o
---- /dev/null
-+++ b/sound/soc/bcm/fe-pi-audio.c
-@@ -0,0 +1,158 @@
-+/*
-+ * ASoC Driver for Fe-Pi Audio Sound Card
-+ *
-+ * Author: Henry Kupis <kuupaz@gmail.com>
-+ * Copyright 2016
-+ * based on code by Florian Meier <florian.meier@koalo.de>
-+ * based on code by Shawn Guo <shawn.guo@linaro.org>
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * version 2 as published by the Free Software Foundation.
-+ *
-+ * This program is distributed in the hope that it will be useful, but
-+ * WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ * General Public License for more details.
-+ */
-+
-+#include <linux/module.h>
-+#include <linux/platform_device.h>
-+#include <linux/io.h>
-+
-+#include <sound/core.h>
-+#include <sound/pcm.h>
-+#include <sound/pcm_params.h>
-+#include <sound/soc.h>
-+#include <sound/jack.h>
-+
-+#include "../codecs/sgtl5000.h"
-+
-+static int snd_fe_pi_audio_init(struct snd_soc_pcm_runtime *rtd)
-+{
-+ struct snd_soc_card *card = rtd->card;
-+ struct snd_soc_codec *codec = rtd->codec;
-+
-+ snd_soc_dapm_force_enable_pin(&card->dapm, "LO");
-+ snd_soc_dapm_force_enable_pin(&card->dapm, "ADC");
-+ snd_soc_dapm_force_enable_pin(&card->dapm, "DAC");
-+ snd_soc_dapm_force_enable_pin(&card->dapm, "HP");
-+ snd_soc_update_bits(codec, SGTL5000_CHIP_ANA_POWER,
-+ SGTL5000_VAG_POWERUP, SGTL5000_VAG_POWERUP);
-+
-+ return 0;
-+}
-+
-+static int snd_fe_pi_audio_hw_params(struct snd_pcm_substream *substream,
-+ struct snd_pcm_hw_params *params)
-+{
-+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
-+ struct device *dev = rtd->card->dev;
-+ struct snd_soc_dai *codec_dai = rtd->codec_dai;
-+
-+ int ret;
-+
-+ /* Set SGTL5000's SYSCLK */
-+ ret = snd_soc_dai_set_sysclk(codec_dai, SGTL5000_SYSCLK, 12288000, SND_SOC_CLOCK_IN);
-+ if (ret) {
-+ dev_err(dev, "could not set codec driver clock params\n");
-+ return ret;
-+ }
-+
-+ return 0;
-+}
-+
-+
-+static struct snd_soc_ops snd_fe_pi_audio_ops = {
-+ .hw_params = snd_fe_pi_audio_hw_params,
-+};
-+
-+static struct snd_soc_dai_link snd_fe_pi_audio_dai[] = {
-+ {
-+ .name = "FE-PI",
-+ .stream_name = "Fe-Pi HiFi",
-+ .cpu_dai_name = "bcm2708-i2s.0",
-+ .codec_dai_name = "sgtl5000",
-+ .platform_name = "bcm2708-i2s.0",
-+ .codec_name = "sgtl5000.1-000a",
-+ .dai_fmt = SND_SOC_DAIFMT_I2S | SND_SOC_DAIFMT_NB_NF |
-+ SND_SOC_DAIFMT_CBM_CFM,
-+ .ops = &snd_fe_pi_audio_ops,
-+ .init = snd_fe_pi_audio_init,
-+ },
-+};
-+
-+static const struct snd_soc_dapm_route fe_pi_audio_dapm_routes[] = {
-+ {"ADC", NULL, "Mic Bias"},
-+};
-+
-+
-+static struct snd_soc_card fe_pi_audio = {
-+ .name = "Fe-Pi Audio",
-+ .owner = THIS_MODULE,
-+ .dai_link = snd_fe_pi_audio_dai,
-+ .num_links = ARRAY_SIZE(snd_fe_pi_audio_dai),
-+
-+ .dapm_routes = fe_pi_audio_dapm_routes,
-+ .num_dapm_routes = ARRAY_SIZE(fe_pi_audio_dapm_routes),
-+};
-+
-+static int snd_fe_pi_audio_probe(struct platform_device *pdev)
-+{
-+ int ret = 0;
-+ struct snd_soc_card *card = &fe_pi_audio;
-+ struct device_node *np = pdev->dev.of_node;
-+ struct device_node *i2s_node;
-+ struct snd_soc_dai_link *dai = &snd_fe_pi_audio_dai[0];
-+
-+ fe_pi_audio.dev = &pdev->dev;
-+
-+ i2s_node = of_parse_phandle(np, "i2s-controller", 0);
-+ if (!i2s_node) {
-+ dev_err(&pdev->dev, "i2s_node phandle missing or invalid\n");
-+ return -EINVAL;
-+ }
-+
-+ dai->cpu_dai_name = NULL;
-+ dai->cpu_of_node = i2s_node;
-+ dai->platform_name = NULL;
-+ dai->platform_of_node = i2s_node;
-+
-+ of_node_put(i2s_node);
-+
-+ card->dev = &pdev->dev;
-+ platform_set_drvdata(pdev, card);
-+
-+ ret = snd_soc_register_card(card);
-+ if (ret && ret != -EPROBE_DEFER)
-+ dev_err(&pdev->dev, "snd_soc_register_card() failed: %d\n", ret);
-+
-+ return ret;
-+}
-+
-+static int snd_fe_pi_audio_remove(struct platform_device *pdev)
-+{
-+ return snd_soc_unregister_card(&fe_pi_audio);
-+}
-+
-+static const struct of_device_id snd_fe_pi_audio_of_match[] = {
-+ { .compatible = "fe-pi,fe-pi-audio", },
-+ {},
-+};
-+MODULE_DEVICE_TABLE(of, snd_fe_pi_audio_of_match);
-+
-+static struct platform_driver snd_fe_pi_audio_driver = {
-+ .driver = {
-+ .name = "snd-fe-pi-audio",
-+ .owner = THIS_MODULE,
-+ .of_match_table = snd_fe_pi_audio_of_match,
-+ },
-+ .probe = snd_fe_pi_audio_probe,
-+ .remove = snd_fe_pi_audio_remove,
-+};
-+
-+module_platform_driver(snd_fe_pi_audio_driver);
-+
-+MODULE_AUTHOR("Henry Kupis <fe-pi@cox.net>");
-+MODULE_DESCRIPTION("ASoC Driver for Fe-Pi Audio");
-+MODULE_LICENSE("GPL v2");