aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-4.4
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/patches-4.4')
-rw-r--r--target/linux/brcm2708/patches-4.4/0029-Add-dwc_otg-driver.patch2
-rw-r--r--target/linux/brcm2708/patches-4.4/0526-x86-boot-Fix-kdump-cleanup-aborted-E820_PRAM-max_pfn.patch2
-rw-r--r--target/linux/brcm2708/patches-4.4/0551-kbuild-add-fno-PIE.patch40
-rw-r--r--target/linux/brcm2708/patches-4.4/0552-kbuild-Steal-gcc-s-pie-from-the-very-beginning.patch49
4 files changed, 2 insertions, 91 deletions
diff --git a/target/linux/brcm2708/patches-4.4/0029-Add-dwc_otg-driver.patch b/target/linux/brcm2708/patches-4.4/0029-Add-dwc_otg-driver.patch
index 965a050542..83c5453a0b 100644
--- a/target/linux/brcm2708/patches-4.4/0029-Add-dwc_otg-driver.patch
+++ b/target/linux/brcm2708/patches-4.4/0029-Add-dwc_otg-driver.patch
@@ -659,7 +659,7 @@ dwc_otg: Remove duplicate gadget probe/unregister function
}
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
-@@ -4997,7 +4997,7 @@ static void port_event(struct usb_hub *h
+@@ -5005,7 +5005,7 @@ static void port_event(struct usb_hub *h
if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
u16 status = 0, unused;
diff --git a/target/linux/brcm2708/patches-4.4/0526-x86-boot-Fix-kdump-cleanup-aborted-E820_PRAM-max_pfn.patch b/target/linux/brcm2708/patches-4.4/0526-x86-boot-Fix-kdump-cleanup-aborted-E820_PRAM-max_pfn.patch
index ce125d4b2f..9b3a5e748f 100644
--- a/target/linux/brcm2708/patches-4.4/0526-x86-boot-Fix-kdump-cleanup-aborted-E820_PRAM-max_pfn.patch
+++ b/target/linux/brcm2708/patches-4.4/0526-x86-boot-Fix-kdump-cleanup-aborted-E820_PRAM-max_pfn.patch
@@ -49,7 +49,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
--- a/arch/x86/kernel/e820.c
+++ b/arch/x86/kernel/e820.c
-@@ -347,7 +347,7 @@ int __init sanitize_e820_map(struct e820
+@@ -348,7 +348,7 @@ int __init sanitize_e820_map(struct e820
* continue building up new bios map based on this
* information
*/
diff --git a/target/linux/brcm2708/patches-4.4/0551-kbuild-add-fno-PIE.patch b/target/linux/brcm2708/patches-4.4/0551-kbuild-add-fno-PIE.patch
deleted file mode 100644
index c3b5adc7c4..0000000000
--- a/target/linux/brcm2708/patches-4.4/0551-kbuild-add-fno-PIE.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From d7c87b54cdabe76c12f2bb527f2a6b02b6255a0f Mon Sep 17 00:00:00 2001
-From: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
-Date: Fri, 4 Nov 2016 19:39:38 +0100
-Subject: [PATCH] kbuild: add -fno-PIE
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-commit 8ae94224c9d72fc4d9aaac93b2d7833cf46d7141 upstream.
-
-Debian started to build the gcc with -fPIE by default so the kernel
-build ends before it starts properly with:
-|kernel/bounds.c:1:0: error: code model kernel does not support PIC mode
-
-Also add to KBUILD_AFLAGS due to:
-
-|gcc -Wp,-MD,arch/x86/entry/vdso/vdso32/.note.o.d … -mfentry -DCC_USING_FENTRY … vdso/vdso32/note.S
-|arch/x86/entry/vdso/vdso32/note.S:1:0: sorry, unimplemented: -mfentry isn’t supported for 32-bit in combination with -fpic
-
-Tagging it stable so it is possible to compile recent stable kernels as
-well.
-
-Signed-off-by: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
-Signed-off-by: Michal Marek <mmarek@suse.com>
-Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
----
- Makefile | 2 ++
- 1 file changed, 2 insertions(+)
-
---- a/Makefile
-+++ b/Makefile
-@@ -624,6 +624,8 @@ KBUILD_CFLAGS += $(call cc-disable-warni
- KBUILD_CFLAGS += $(call cc-disable-warning, format-truncation)
- KBUILD_CFLAGS += $(call cc-disable-warning, format-overflow)
- KBUILD_CFLAGS += $(call cc-disable-warning, int-in-bool-context)
-+KBUILD_CFLAGS += $(call cc-option,-fno-PIE)
-+KBUILD_AFLAGS += $(call cc-option,-fno-PIE)
-
- ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
- KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION)
diff --git a/target/linux/brcm2708/patches-4.4/0552-kbuild-Steal-gcc-s-pie-from-the-very-beginning.patch b/target/linux/brcm2708/patches-4.4/0552-kbuild-Steal-gcc-s-pie-from-the-very-beginning.patch
deleted file mode 100644
index de20f9e8c4..0000000000
--- a/target/linux/brcm2708/patches-4.4/0552-kbuild-Steal-gcc-s-pie-from-the-very-beginning.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From e1c194ad704d298d6914e5b1efc4afee41a18a4c Mon Sep 17 00:00:00 2001
-From: Borislav Petkov <bp@suse.de>
-Date: Mon, 14 Nov 2016 19:41:31 +0100
-Subject: [PATCH] kbuild: Steal gcc's pie from the very beginning
-
-commit c6a385539175ebc603da53aafb7753d39089f32e upstream.
-
-So Sebastian turned off the PIE for kernel builds but that was too late
-- Kbuild.include already uses KBUILD_CFLAGS and trying to disable gcc
-options with, say cc-disable-warning, fails:
-
- gcc -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs
- ...
- -Wno-sign-compare -fno-asynchronous-unwind-tables -Wframe-address -c -x c /dev/null -o .31392.tmp
- /dev/null:1:0: error: code model kernel does not support PIC mode
-
-because that returns an error and we can't disable the warning. For
-example in this case:
-
-KBUILD_CFLAGS += $(call cc-disable-warning,frame-address,)
-
-which leads to gcc issuing all those warnings again.
-
-So let's turn off PIE/PIC at the earliest possible moment, when we
-declare KBUILD_CFLAGS so that cc-disable-warning picks it up too.
-
-Also, we need the $(call cc-option ...) because -fno-PIE is supported
-since gcc v3.4 and our lowest supported gcc version is 3.2 right now.
-
-Signed-off-by: Borislav Petkov <bp@suse.de>
-Cc: Ben Hutchings <ben@decadent.org.uk>
-Cc: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
-Signed-off-by: Michal Marek <mmarek@suse.com>
-Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
----
- Makefile | 2 --
- 1 file changed, 2 deletions(-)
-
---- a/Makefile
-+++ b/Makefile
-@@ -624,8 +624,6 @@ KBUILD_CFLAGS += $(call cc-disable-warni
- KBUILD_CFLAGS += $(call cc-disable-warning, format-truncation)
- KBUILD_CFLAGS += $(call cc-disable-warning, format-overflow)
- KBUILD_CFLAGS += $(call cc-disable-warning, int-in-bool-context)
--KBUILD_CFLAGS += $(call cc-option,-fno-PIE)
--KBUILD_AFLAGS += $(call cc-option,-fno-PIE)
-
- ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
- KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION)