aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-4.14/950-0316-overlays-Add-gpio-no-irq-overlay.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/patches-4.14/950-0316-overlays-Add-gpio-no-irq-overlay.patch')
-rw-r--r--target/linux/brcm2708/patches-4.14/950-0316-overlays-Add-gpio-no-irq-overlay.patch60
1 files changed, 0 insertions, 60 deletions
diff --git a/target/linux/brcm2708/patches-4.14/950-0316-overlays-Add-gpio-no-irq-overlay.patch b/target/linux/brcm2708/patches-4.14/950-0316-overlays-Add-gpio-no-irq-overlay.patch
deleted file mode 100644
index ba0e4094da..0000000000
--- a/target/linux/brcm2708/patches-4.14/950-0316-overlays-Add-gpio-no-irq-overlay.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From 174a2e7f83a033252da488edd3072f446f82325d Mon Sep 17 00:00:00 2001
-From: Phil Elwell <phil@raspberrypi.org>
-Date: Tue, 19 Jun 2018 15:04:45 +0100
-Subject: [PATCH 316/454] overlays: Add gpio-no-irq overlay
-
-An overlay to disable all GPIO interrupts.
-
-See: https://github.com/raspberrypi/linux/issues/2550
-
-Signed-off-by: Phil Elwell <phil@raspberrypi.org>
----
- arch/arm/boot/dts/overlays/Makefile | 1 +
- arch/arm/boot/dts/overlays/README | 7 +++++++
- arch/arm/boot/dts/overlays/gpio-no-irq-overlay.dts | 14 ++++++++++++++
- 3 files changed, 22 insertions(+)
- create mode 100644 arch/arm/boot/dts/overlays/gpio-no-irq-overlay.dts
-
---- a/arch/arm/boot/dts/overlays/Makefile
-+++ b/arch/arm/boot/dts/overlays/Makefile
-@@ -35,6 +35,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
- gpio-ir.dtbo \
- gpio-ir-tx.dtbo \
- gpio-key.dtbo \
-+ gpio-no-irq.dtbo \
- gpio-poweroff.dtbo \
- gpio-shutdown.dtbo \
- hifiberry-amp.dtbo \
---- a/arch/arm/boot/dts/overlays/README
-+++ b/arch/arm/boot/dts/overlays/README
-@@ -583,6 +583,13 @@ Params: gpio GPIO pin
- keycode Set the key code for the button
-
-
-+Name: gpio-no-irq
-+Info: Use this overlay to disable all GPIO interrupts, which can be useful
-+ for user-space GPIO edge detection systems.
-+Load: dtoverlay=gpio-no-irq
-+Params: <None>
-+
-+
- Name: gpio-poweroff
- Info: Drives a GPIO high or low on poweroff (including halt). Enabling this
- overlay will prevent the ability to boot by driving GPIO3 low.
---- /dev/null
-+++ b/arch/arm/boot/dts/overlays/gpio-no-irq-overlay.dts
-@@ -0,0 +1,14 @@
-+/dts-v1/;
-+/plugin/;
-+
-+/ {
-+ compatible = "brcm,bcm2835";
-+
-+ fragment@0 {
-+ // Configure the gpio pin controller
-+ target = <&gpio>;
-+ __overlay__ {
-+ interrupts;
-+ };
-+ };
-+};