aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-4.14/950-0172-drm-vc4-Use-correct-path-to-trace-include.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/patches-4.14/950-0172-drm-vc4-Use-correct-path-to-trace-include.patch')
-rw-r--r--target/linux/brcm2708/patches-4.14/950-0172-drm-vc4-Use-correct-path-to-trace-include.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/target/linux/brcm2708/patches-4.14/950-0172-drm-vc4-Use-correct-path-to-trace-include.patch b/target/linux/brcm2708/patches-4.14/950-0172-drm-vc4-Use-correct-path-to-trace-include.patch
new file mode 100644
index 0000000000..5af758a732
--- /dev/null
+++ b/target/linux/brcm2708/patches-4.14/950-0172-drm-vc4-Use-correct-path-to-trace-include.patch
@@ -0,0 +1,43 @@
+From 3af0d509b5718cfe7fbaf8c97e769d3df3743de0 Mon Sep 17 00:00:00 2001
+From: Thierry Reding <treding@nvidia.com>
+Date: Fri, 1 Sep 2017 16:49:54 +0200
+Subject: [PATCH 172/454] drm/vc4: Use correct path to trace include
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The header comment in include/trace/define_trace.h specifies that the
+TRACE_INCLUDE_PATH needs to be relative to the define_trace.h header
+rather than the trace file including it. Most instances get that wrong
+and work around it by adding the $(src) directory to the include path.
+
+While this works, it is preferable to refer to the correct path to the
+trace file in the first place and avoid any workaround.
+
+Acked-by: Christian König <christian.koenig@amd.com>
+Acked-by: Daniel Vetter <daniel.vetter@ffwll.ch>
+Signed-off-by: Thierry Reding <treding@nvidia.com>
+Link: https://patchwork.freedesktop.org/patch/msgid/20170901144954.19620-6-thierry.reding@gmail.com
+(cherry picked from commit ff58a15a502a900c35ff2f20182249b65719d6d7)
+---
+ drivers/gpu/drm/vc4/Makefile | 2 --
+ drivers/gpu/drm/vc4/vc4_trace.h | 2 +-
+ 2 files changed, 1 insertion(+), 3 deletions(-)
+
+--- a/drivers/gpu/drm/vc4/Makefile
++++ b/drivers/gpu/drm/vc4/Makefile
+@@ -26,5 +26,3 @@ vc4-y := \
+ vc4-$(CONFIG_DEBUG_FS) += vc4_debugfs.o
+
+ obj-$(CONFIG_DRM_VC4) += vc4.o
+-
+-CFLAGS_vc4_trace_points.o := -I$(src)
+--- a/drivers/gpu/drm/vc4/vc4_trace.h
++++ b/drivers/gpu/drm/vc4/vc4_trace.h
+@@ -59,5 +59,5 @@ TRACE_EVENT(vc4_wait_for_seqno_end,
+
+ /* This part must be outside protection */
+ #undef TRACE_INCLUDE_PATH
+-#define TRACE_INCLUDE_PATH .
++#define TRACE_INCLUDE_PATH ../../drivers/gpu/drm/vc4
+ #include <trace/define_trace.h>