aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-3.14/0036-ASoC-Add-support-for-PCM5102A-codec.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/patches-3.14/0036-ASoC-Add-support-for-PCM5102A-codec.patch')
-rw-r--r--target/linux/brcm2708/patches-3.14/0036-ASoC-Add-support-for-PCM5102A-codec.patch120
1 files changed, 0 insertions, 120 deletions
diff --git a/target/linux/brcm2708/patches-3.14/0036-ASoC-Add-support-for-PCM5102A-codec.patch b/target/linux/brcm2708/patches-3.14/0036-ASoC-Add-support-for-PCM5102A-codec.patch
deleted file mode 100644
index 0b491e7687..0000000000
--- a/target/linux/brcm2708/patches-3.14/0036-ASoC-Add-support-for-PCM5102A-codec.patch
+++ /dev/null
@@ -1,120 +0,0 @@
-From c2155e69578ea9f02c915960599bb5216ce860c1 Mon Sep 17 00:00:00 2001
-From: Florian Meier <florian.meier@koalo.de>
-Date: Fri, 22 Nov 2013 14:59:51 +0100
-Subject: [PATCH 36/54] ASoC: Add support for PCM5102A codec
-
-Some definitions to support the PCM5102A codec
-by Texas Instruments.
-
-Signed-off-by: Florian Meier <florian.meier@koalo.de>
----
- sound/soc/codecs/Kconfig | 4 +++
- sound/soc/codecs/Makefile | 2 ++
- sound/soc/codecs/pcm5102a.c | 63 +++++++++++++++++++++++++++++++++++++++++++++
- 3 files changed, 69 insertions(+)
- create mode 100644 sound/soc/codecs/pcm5102a.c
-
---- a/sound/soc/codecs/Kconfig
-+++ b/sound/soc/codecs/Kconfig
-@@ -59,6 +59,7 @@ config SND_SOC_ALL_CODECS
- select SND_SOC_PCM1681 if I2C
- select SND_SOC_PCM1792A if SPI_MASTER
- select SND_SOC_PCM3008
-+ select SND_SOC_PCM5102A
- select SND_SOC_RT5631 if I2C
- select SND_SOC_RT5640 if I2C
- select SND_SOC_SGTL5000 if I2C
-@@ -313,6 +314,9 @@ config SND_SOC_PCM1792A
- config SND_SOC_PCM3008
- tristate
-
-+config SND_SOC_PCM5102A
-+ tristate
-+
- config SND_SOC_RT5631
- tristate
-
---- a/sound/soc/codecs/Makefile
-+++ b/sound/soc/codecs/Makefile
-@@ -46,6 +46,7 @@ snd-soc-hdmi-codec-objs := hdmi.o
- snd-soc-pcm1681-objs := pcm1681.o
- snd-soc-pcm1792a-codec-objs := pcm1792a.o
- snd-soc-pcm3008-objs := pcm3008.o
-+snd-soc-pcm5102a-objs := pcm5102a.o
- snd-soc-rt5631-objs := rt5631.o
- snd-soc-rt5640-objs := rt5640.o
- snd-soc-sgtl5000-objs := sgtl5000.o
-@@ -179,6 +180,7 @@ obj-$(CONFIG_SND_SOC_HDMI_CODEC) += snd-
- obj-$(CONFIG_SND_SOC_PCM1681) += snd-soc-pcm1681.o
- obj-$(CONFIG_SND_SOC_PCM1792A) += snd-soc-pcm1792a-codec.o
- obj-$(CONFIG_SND_SOC_PCM3008) += snd-soc-pcm3008.o
-+obj-$(CONFIG_SND_SOC_PCM5102A) += snd-soc-pcm5102a.o
- obj-$(CONFIG_SND_SOC_RT5631) += snd-soc-rt5631.o
- obj-$(CONFIG_SND_SOC_RT5640) += snd-soc-rt5640.o
- obj-$(CONFIG_SND_SOC_SGTL5000) += snd-soc-sgtl5000.o
---- /dev/null
-+++ b/sound/soc/codecs/pcm5102a.c
-@@ -0,0 +1,63 @@
-+/*
-+ * Driver for the PCM5102A codec
-+ *
-+ * Author: Florian Meier <florian.meier@koalo.de>
-+ * Copyright 2013
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * version 2 as published by the Free Software Foundation.
-+ *
-+ * This program is distributed in the hope that it will be useful, but
-+ * WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ * General Public License for more details.
-+ */
-+
-+
-+#include <linux/init.h>
-+#include <linux/module.h>
-+#include <linux/platform_device.h>
-+
-+#include <sound/soc.h>
-+
-+static struct snd_soc_dai_driver pcm5102a_dai = {
-+ .name = "pcm5102a-hifi",
-+ .playback = {
-+ .channels_min = 2,
-+ .channels_max = 2,
-+ .rates = SNDRV_PCM_RATE_8000_192000,
-+ .formats = SNDRV_PCM_FMTBIT_S16_LE |
-+ SNDRV_PCM_FMTBIT_S24_LE |
-+ SNDRV_PCM_FMTBIT_S32_LE
-+ },
-+};
-+
-+static struct snd_soc_codec_driver soc_codec_dev_pcm5102a;
-+
-+static int pcm5102a_probe(struct platform_device *pdev)
-+{
-+ return snd_soc_register_codec(&pdev->dev, &soc_codec_dev_pcm5102a,
-+ &pcm5102a_dai, 1);
-+}
-+
-+static int pcm5102a_remove(struct platform_device *pdev)
-+{
-+ snd_soc_unregister_codec(&pdev->dev);
-+ return 0;
-+}
-+
-+static struct platform_driver pcm5102a_codec_driver = {
-+ .probe = pcm5102a_probe,
-+ .remove = pcm5102a_remove,
-+ .driver = {
-+ .name = "pcm5102a-codec",
-+ .owner = THIS_MODULE,
-+ },
-+};
-+
-+module_platform_driver(pcm5102a_codec_driver);
-+
-+MODULE_DESCRIPTION("ASoC PCM5102A codec driver");
-+MODULE_AUTHOR("Florian Meier <florian.meier@koalo.de>");
-+MODULE_LICENSE("GPL v2");