aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/modules/hwmon.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/modules/hwmon.mk')
-rw-r--r--target/linux/brcm2708/modules/hwmon.mk36
1 files changed, 0 insertions, 36 deletions
diff --git a/target/linux/brcm2708/modules/hwmon.mk b/target/linux/brcm2708/modules/hwmon.mk
deleted file mode 100644
index 9b790010b3..0000000000
--- a/target/linux/brcm2708/modules/hwmon.mk
+++ /dev/null
@@ -1,36 +0,0 @@
-#
-# Copyright (C) 2019 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define KernelPackage/hwmon-raspberrypi
- TITLE:=Raspberry Pi voltage monitor
- KCONFIG:=CONFIG_SENSORS_RASPBERRYPI_HWMON
- FILES:=$(LINUX_DIR)/drivers/hwmon/raspberrypi-hwmon.ko
- AUTOLOAD:=$(call AutoLoad,60,raspberrypi-hwmon)
- $(call AddDepends/hwmon,@TARGET_brcm2708)
-endef
-
-define KernelPackage/hwmon-raspberrypi/description
- Kernel module for voltage sensor on the Raspberry Pi
-endef
-
-$(eval $(call KernelPackage,hwmon-raspberrypi))
-
-
-define KernelPackage/hwmon-rpi-poe-fan
- SUBMENU:=$(HWMON_MENU)
- TITLE:=Raspberry Pi PoE HAT fan
- DEPENDS:=@TARGET_brcm2708 +kmod-hwmon-core
- KCONFIG:=CONFIG_SENSORS_RPI_POE_FAN
- FILES:=$(LINUX_DIR)/drivers/hwmon/rpi-poe-fan.ko
- AUTOLOAD:=$(call AutoProbe,rpi-poe-fan)
-endef
-
-define KernelPackage/hwmon-rpi-poe-fan/description
- Raspberry Pi PoE HAT fan driver
-endef
-
-$(eval $(call KernelPackage,hwmon-rpi-poe-fan))