aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/image')
-rw-r--r--target/linux/brcm2708/image/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 7909c6d814..41730b6803 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -50,13 +50,14 @@ define Device/Default
FILESYSTEMS := ext4
KERNEL := kernel-bin | kernel-img
KERNEL_IMG := kernel.img
- IMAGES := sdcard.img
- IMAGE/sdcard.img := boot-img | sdcard-img
+ IMAGES := sdcard.img.gz
+ IMAGE/sdcard.img.gz := boot-img | sdcard-img | gzip | append-metadata
endef
define Device/rpi
DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero/ZeroW
DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-0-w
+ SUPPORTED_DEVICES := rpi-b rpi-b-plus rpi-cm rpi-zero-w
endef
ifeq ($(SUBTARGET),bcm2708)
TARGET_DEVICES += rpi
@@ -65,6 +66,7 @@ endif
define Device/rpi-2
DEVICE_TITLE := Raspberry Pi 2B/3B/3CM
DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-cm3
+ SUPPORTED_DEVICES := rpi-2-b rpi-3-b rpi-cm
endef
ifeq ($(SUBTARGET),bcm2709)
TARGET_DEVICES += rpi-2
@@ -74,6 +76,7 @@ define Device/rpi-3
KERNEL_IMG := kernel8.img
DEVICE_TITLE := Raspberry Pi 3B (64 bit)
DEVICE_DTS := broadcom/bcm2710-rpi-3-b
+ SUPPORTED_DEVICES := rpi-3-b
endef
ifeq ($(SUBTARGET),bcm2710)
TARGET_DEVICES += rpi-3