aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 96ea887e88..a9afa4e915 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -61,6 +61,7 @@ endef
### Devices ###
define Device/Default
+ DEVICE_VENDOR := Raspberry Pi
KERNEL := kernel-bin | kernel-img
KERNEL_IMG := kernel.img
IMAGES := factory.img.gz sysupgrade.img.gz
@@ -70,7 +71,7 @@ define Device/Default
endef
define Device/rpi
- DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero/ZeroW
+ DEVICE_MODEL := B/B+/CM/Zero/ZeroW
DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-zero bcm2708-rpi-zero-w
SUPPORTED_DEVICES := \
rpi-b rpi-b-plus rpi-cm rpi-zero rpi-zero-w \
@@ -87,7 +88,7 @@ ifeq ($(SUBTARGET),bcm2708)
endif
define Device/rpi-2
- DEVICE_TITLE := Raspberry Pi 2B/3B/3B+/3CM/4B
+ DEVICE_MODEL := 2B/3B/3B+/3CM/4B
DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-3-b-plus bcm2711-rpi-4-b bcm2710-rpi-cm3
SUPPORTED_DEVICES := \
rpi-2-b rpi-3-b rpi-3-b-plus rpi-cm \
@@ -109,8 +110,8 @@ ifeq ($(SUBTARGET),bcm2709)
endif
define Device/rpi-3
+ DEVICE_MODEL := 3B/3B+/3CM
KERNEL_IMG := kernel8.img
- DEVICE_TITLE := Raspberry Pi 3B/3B+/3CM
DEVICE_DTS := broadcom/bcm2710-rpi-3-b broadcom/bcm2710-rpi-3-b-plus broadcom/bcm2710-rpi-cm3
SUPPORTED_DEVICES := \
rpi-3-b rpi-3-b-plus \
@@ -128,6 +129,7 @@ ifeq ($(SUBTARGET),bcm2710)
endif
define Device/rpi-4
+ DEVICE_MODEL := 4B
KERNEL_IMG := kernel8.img
DEVICE_TITLE := Raspberry Pi 4B
DEVICE_DTS := broadcom/bcm2711-rpi-4-b