aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index de222f0801..7a68c506cf 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -22,10 +22,6 @@ else
endif
### Image scripts ###
-define Build/build-dtb
- $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
-endef
-
define Build/gen-cfg
cat config.txt > $@.config
echo -e "\ndevice_tree=$(DEVICE_DTS).dtb" >> $@.config
@@ -44,7 +40,7 @@ define Build/boot-img
mcopy -i $@.boot cmdline.txt ::
mcopy -i $@.boot $@.config ::config.txt
mcopy -i $@.boot $(word 1,$^) ::kernel.img
- mcopy -i $@.boot $@.dtb ::$(DEVICE_DTS).dtb
+ mcopy -i $@.boot $(DTS_DIR)/$(DEVICE_DTS).dtb ::$(DEVICE_DTS).dtb
endef
define Build/sdcard-img
@@ -59,7 +55,7 @@ define Device/Default
PROFILES = Default $$(DEVICE_PROFILE)
KERNEL := kernel-bin
IMAGES := sdcard.bin
- IMAGE/sdcard.bin := build-dtb | gen-cfg | boot-img | sdcard-img
+ IMAGE/sdcard.bin := gen-cfg | boot-img | sdcard-img
DEVICE_PROFILE :=
DEVICE_DTS :=
endef