aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/bcm2709
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/bcm2709')
-rw-r--r--target/linux/brcm2708/bcm2709/config-default17
-rw-r--r--target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk16
-rw-r--r--target/linux/brcm2708/bcm2709/target.mk7
3 files changed, 40 insertions, 0 deletions
diff --git a/target/linux/brcm2708/bcm2709/config-default b/target/linux/brcm2708/bcm2709/config-default
new file mode 100644
index 0000000000..e9d87ca659
--- /dev/null
+++ b/target/linux/brcm2708/bcm2709/config-default
@@ -0,0 +1,17 @@
+CONFIG_ARCH_BCM2709=y
+# CONFIG_ARM_LPAE is not set
+# CONFIG_ARM_THUMBEE is not set
+CONFIG_ARM_ARCH_TIMER_EVTSTREAM=y
+CONFIG_BCM2708_NOL2CACHE=y
+# CONFIG_BCM2709_DT is not set
+# CONFIG_CRYPTO_SHA1_ARM_NEON is not set
+# CONFIG_CRYPTO_SHA512_ARM_NEON is not set
+CONFIG_HAVE_ARM_ARCH_TIMER=y
+CONFIG_KERNEL_MODE_NEON=y
+CONFIG_LOCALVERSION="-v7"
+CONFIG_NEON=y
+CONFIG_NR_CPUS=4
+CONFIG_SMP=y
+CONFIG_SMP_ON_UP=y
+# CONFIG_THUMB2_KERNEL is not set
+CONFIG_VMSPLIT_2G=y
diff --git a/target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk b/target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk
new file mode 100644
index 0000000000..d3d1617176
--- /dev/null
+++ b/target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RaspberryPi2
+ NAME:=Raspberry Pi 2
+endef
+
+define Profile/RaspberryPi2/Description
+ Raspberry Pi 2 board
+endef
+
+$(eval $(call Profile,RaspberryPi2))
diff --git a/target/linux/brcm2708/bcm2709/target.mk b/target/linux/brcm2708/bcm2709/target.mk
new file mode 100644
index 0000000000..610c6b0abc
--- /dev/null
+++ b/target/linux/brcm2708/bcm2709/target.mk
@@ -0,0 +1,7 @@
+BOARDNAME:=bcm2709
+CPU_TYPE:=cortex-a7
+CPU_SUBTYPE:=vfp
+
+define Target/Description
+ Build firmware image for Broadcom BCM2709 SoC devices.
+endef