aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image/bcm6328.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bmips/image/bcm6328.mk')
-rw-r--r--target/linux/bmips/image/bcm6328.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm6328.mk b/target/linux/bmips/image/bcm6328.mk
index 8023ef8fa1..fd0cf16dbb 100644
--- a/target/linux/bmips/image/bcm6328.mk
+++ b/target/linux/bmips/image/bcm6328.mk
@@ -1,5 +1,18 @@
# SPDX-License-Identifier: GPL-2.0-or-later
+define Device/arcadyan_ar7516
+ $(Device/bcm63xx-cfe)
+ DEVICE_VENDOR := Arcadyan
+ DEVICE_MODEL := AR7516
+ CHIP_ID := 6328
+ CFE_BOARD_ID := AR7516AAW
+ FLASH_MB := 8
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES) broadcom-43227-sprom \
+ kmod-leds-bcm6328
+endef
+TARGET_DEVICES += arcadyan_ar7516
+
define Device/comtrend_ar-5381u
$(Device/bcm63xx-cfe)
DEVICE_VENDOR := Comtrend