aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image/bcm63268.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bmips/image/bcm63268.mk')
-rw-r--r--target/linux/bmips/image/bcm63268.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm63268.mk b/target/linux/bmips/image/bcm63268.mk
index 6e27b16624..941e83f71b 100644
--- a/target/linux/bmips/image/bcm63268.mk
+++ b/target/linux/bmips/image/bcm63268.mk
@@ -1,5 +1,24 @@
# SPDX-License-Identifier: GPL-2.0-or-later
+define Device/comtrend_vg-8050
+ $(Device/bcm63xx-nand)
+ DEVICE_VENDOR := Comtrend
+ DEVICE_MODEL := VG-8050
+ CHIP_ID := 63268
+ SOC := bcm63169
+ CFE_RAM_FILE := comtrend,vg-8050/cferam.000
+ CFE_RAM_JFFS2_NAME := cferam.000
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ VID_HDR_OFFSET := 2048
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ kmod-leds-bcm6328
+ CFE_WFI_FLASH_TYPE := 3
+ CFE_WFI_VERSION := 0x5732
+endef
+TARGET_DEVICES += comtrend_vg-8050
+
define Device/comtrend_vr-3032u
$(Device/bcm63xx-nand)
DEVICE_VENDOR := Comtrend