aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bmips/image/Makefile')
-rw-r--r--target/linux/bmips/image/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/target/linux/bmips/image/Makefile b/target/linux/bmips/image/Makefile
index 907779847d..da328f7216 100644
--- a/target/linux/bmips/image/Makefile
+++ b/target/linux/bmips/image/Makefile
@@ -194,12 +194,18 @@ define Build/cfe-sercomm-crypto
endef
define Build/cfe-sercomm-load
+ $(TOPDIR)/scripts/sercomm-pid.py \
+ --hw-version $(SERCOMM_HWVER) \
+ --sw-version $(SERCOMM_SWVER) \
+ --extra-padding-size 0x10 \
+ --pid-file $@.pid
$(TOPDIR)/scripts/sercomm-payload.py \
--input-file $@ \
--output-file $@.new \
- --pid "$(SERCOMM_PID)"
+ --pid-file $@.pid
mv $@.new $@
+ rm -f $@.pid
endef
define Build/cfe-sercomm-part