aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx/smp
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm63xx/smp')
-rw-r--r--target/linux/bcm63xx/smp/config-default17
-rw-r--r--target/linux/bcm63xx/smp/target.mk8
2 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/bcm63xx/smp/config-default b/target/linux/bcm63xx/smp/config-default
new file mode 100644
index 0000000000..935e97f91a
--- /dev/null
+++ b/target/linux/bcm63xx/smp/config-default
@@ -0,0 +1,17 @@
+CONFIG_CPU_RMAP=y
+CONFIG_CRYPTO_AEAD=y
+CONFIG_CRYPTO_AEAD2=y
+CONFIG_CRYPTO_HASH2=y
+CONFIG_CRYPTO_MANAGER=y
+CONFIG_CRYPTO_MANAGER2=y
+CONFIG_CRYPTO_NULL2=y
+CONFIG_NET_FLOW_LIMIT=y
+CONFIG_NR_CPUS=2
+CONFIG_PADATA=y
+CONFIG_RCU_STALL_COMMON=y
+CONFIG_RFS_ACCEL=y
+CONFIG_RPS=y
+CONFIG_SMP=y
+CONFIG_SMP_UP=y
+CONFIG_TREE_RCU=y
+CONFIG_XPS=y
diff --git a/target/linux/bcm63xx/smp/target.mk b/target/linux/bcm63xx/smp/target.mk
new file mode 100644
index 0000000000..b0ccf97498
--- /dev/null
+++ b/target/linux/bcm63xx/smp/target.mk
@@ -0,0 +1,8 @@
+BOARDNAME:=smp
+
+define Target/Description
+ Build firmware images for BCM63XX boards with SMP support.
+ Currently only BCM6362 and BCM6368 supported.
+endef
+
+