aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm63xx/Makefile')
-rw-r--r--target/linux/bcm63xx/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/bcm63xx/Makefile b/target/linux/bcm63xx/Makefile
new file mode 100644
index 0000000000..b31d86bb8d
--- /dev/null
+++ b/target/linux/bcm63xx/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2006-2019 OpenWrt.org
+# Copyright (C) 2016 LEDE project
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=bcm63xx
+BOARDNAME:=Broadcom BCM63xx
+SUBTARGETS:=generic smp
+FEATURES:=squashfs usb atm pci pcmcia usbgadget
+KERNEL_PATCHVER:=4.14
+KERNEL_TESTING_PATCHVER:=4.19
+MAINTAINER:=Jonas Gorski <jogo@openwrt.org>
+
+define Target/Description
+ Build firmware images for Broadcom based xDSL/routers
+ currently supports BCM6338, BCM6348 and BCM6358 based devices.
+ (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += swconfig kmod-gpio-button-hotplug
+
+$(eval $(call BuildTarget))