aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm53xx')
-rwxr-xr-xtarget/linux/bcm53xx/base-files/etc/board.d/02_network6
-rwxr-xr-xtarget/linux/bcm53xx/base-files/etc/init.d/clear_partialboot13
-rw-r--r--target/linux/bcm53xx/image/Makefile1
-rw-r--r--target/linux/bcm53xx/patches-5.4/700-b53-add-hacky-CPU-port-fixes-for-devices-not-using-p.patch5
4 files changed, 22 insertions, 3 deletions
diff --git a/target/linux/bcm53xx/base-files/etc/board.d/02_network b/target/linux/bcm53xx/base-files/etc/board.d/02_network
index 231566cfa0..7b039beabe 100755
--- a/target/linux/bcm53xx/base-files/etc/board.d/02_network
+++ b/target/linux/bcm53xx/base-files/etc/board.d/02_network
@@ -31,6 +31,10 @@ bcm53xx_setup_interfaces()
ucidef_add_switch "switch0" \
"0:lan" "1:lan" "2:lan" "3:lan" "4:wan" "5t@eth0"
;;
+ linksys,panamera)
+ ucidef_add_switch "switch1" \
+ "0:lan" "1:lan:7" "2:lan:4" "3:lan:8" "4:wan" "5t@eth0"
+ ;;
luxul,abr-4500-v1|\
luxul,xbr-4500-v1)
ucidef_add_switch "switch0" \
@@ -84,6 +88,7 @@ bcm53xx_setup_macs()
case "$board" in
dlink,dir-885l | \
+ linksys,panamera | \
netgear,r7900 | \
netgear,r8000 | \
netgear,r8500)
@@ -105,6 +110,7 @@ bcm53xx_setup_macs()
offset=1
;;
dlink,dir-885l | \
+ linksys,panamera | \
netgear,r7900 | \
netgear,r8000 | \
netgear,r8500)
diff --git a/target/linux/bcm53xx/base-files/etc/init.d/clear_partialboot b/target/linux/bcm53xx/base-files/etc/init.d/clear_partialboot
new file mode 100755
index 0000000000..b3eddf4af0
--- /dev/null
+++ b/target/linux/bcm53xx/base-files/etc/init.d/clear_partialboot
@@ -0,0 +1,13 @@
+#!/bin/sh /etc/rc.common
+
+START=97
+boot() {
+ . /lib/functions.sh
+
+ case $(board_name) in
+ linksys,panamera)
+ # clear partialboots
+ nvram set partialboots=0 && nvram commit
+ ;;
+ esac
+}
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 0ba067d364..9580723273 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -274,7 +274,6 @@ define Device/linksys_ea9500
DEVICE_MODEL := EA9500
DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
DEVICE_DTS := bcm47094-linksys-panamera
- BROKEN := y
endef
TARGET_DEVICES += linksys_ea9500
diff --git a/target/linux/bcm53xx/patches-5.4/700-b53-add-hacky-CPU-port-fixes-for-devices-not-using-p.patch b/target/linux/bcm53xx/patches-5.4/700-b53-add-hacky-CPU-port-fixes-for-devices-not-using-p.patch
index a5f13afe02..a6d0f119ec 100644
--- a/target/linux/bcm53xx/patches-5.4/700-b53-add-hacky-CPU-port-fixes-for-devices-not-using-p.patch
+++ b/target/linux/bcm53xx/patches-5.4/700-b53-add-hacky-CPU-port-fixes-for-devices-not-using-p.patch
@@ -21,7 +21,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
#include "b53_regs.h"
#include "b53_priv.h"
-@@ -1587,6 +1588,28 @@ static int b53_switch_init(struct b53_de
+@@ -1587,6 +1588,29 @@ static int b53_switch_init(struct b53_de
return ret;
}
@@ -44,7 +44,8 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ * For some reason it doesn't work (no packets on eth2).
+ */
+ if (of_machine_is_compatible("netgear,r7900") ||
-+ of_machine_is_compatible("netgear,r8000"))
++ of_machine_is_compatible("netgear,r8000") ||
++ (of_machine_is_compatible("linksys,panamera") && dev->chip_id == BCM53012_DEVICE_ID))
+ sw_dev->cpu_port = 5;
+
dev->enabled_ports |= BIT(sw_dev->cpu_port);