aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/patches-4.14/032-v4.18-0005-ARM-dts-BCM5301X-Add-DT-for-Luxul-XAP-1610.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm53xx/patches-4.14/032-v4.18-0005-ARM-dts-BCM5301X-Add-DT-for-Luxul-XAP-1610.patch')
-rw-r--r--target/linux/bcm53xx/patches-4.14/032-v4.18-0005-ARM-dts-BCM5301X-Add-DT-for-Luxul-XAP-1610.patch90
1 files changed, 90 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/patches-4.14/032-v4.18-0005-ARM-dts-BCM5301X-Add-DT-for-Luxul-XAP-1610.patch b/target/linux/bcm53xx/patches-4.14/032-v4.18-0005-ARM-dts-BCM5301X-Add-DT-for-Luxul-XAP-1610.patch
new file mode 100644
index 0000000000..a6102857c3
--- /dev/null
+++ b/target/linux/bcm53xx/patches-4.14/032-v4.18-0005-ARM-dts-BCM5301X-Add-DT-for-Luxul-XAP-1610.patch
@@ -0,0 +1,90 @@
+From 6054cb5788072e214af582c42d9bd8c5ffa6e288 Mon Sep 17 00:00:00 2001
+From: Dan Haab <riproute@gmail.com>
+Date: Fri, 4 May 2018 10:08:44 -0600
+Subject: [PATCH] ARM: dts: BCM5301X: Add DT for Luxul XAP-1610
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+It's an access point based on BCM47094 SoC with two BCM4366E wireless
+chipsets.
+
+Signed-off-by: Dan Haab <dan.haab@luxul.com>
+Acked-by: Rafał Miłecki <rafal@milecki.pl>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/boot/dts/Makefile | 1 +
+ arch/arm/boot/dts/bcm47094-luxul-xap-1610.dts | 57 +++++++++++++++++++++++++++
+ 2 files changed, 58 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm47094-luxul-xap-1610.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -102,6 +102,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+ bcm47094-dlink-dir-885l.dtb \
+ bcm47094-linksys-panamera.dtb \
+ bcm47094-luxul-abr-4500.dtb \
++ bcm47094-luxul-xap-1610.dtb \
+ bcm47094-luxul-xbr-4500.dtb \
+ bcm47094-luxul-xwr-3100.dtb \
+ bcm47094-luxul-xwr-3150-v1.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm47094-luxul-xap-1610.dts
+@@ -0,0 +1,57 @@
++// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
++/*
++ * Copyright 2018 Luxul Inc.
++ */
++
++/dts-v1/;
++
++#include "bcm47094.dtsi"
++
++/ {
++ compatible = "luxul,xap-1610-v1", "brcm,bcm47094", "brcm,bcm4708";
++ model = "Luxul XAP-1610 V1";
++
++ chosen {
++ bootargs = "earlycon";
++ };
++
++ memory {
++ reg = <0x00000000 0x08000000>;
++ };
++
++ leds {
++ compatible = "gpio-leds";
++
++ status {
++ label = "bcm53xx:green:status";
++ gpios = <&chipcommon 0 GPIO_ACTIVE_LOW>;
++ linux,default-trigger = "timer";
++ };
++
++ 2ghz {
++ label = "bcm53xx:blue:2ghz";
++ gpios = <&chipcommon 13 GPIO_ACTIVE_LOW>;
++ };
++
++ 5ghz {
++ label = "bcm53xx:blue:5ghz";
++ gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
++ };
++ };
++
++ gpio-keys {
++ compatible = "gpio-keys";
++ #address-cells = <1>;
++ #size-cells = <0>;
++
++ restart {
++ label = "Reset";
++ linux,code = <KEY_RESTART>;
++ gpios = <&chipcommon 17 GPIO_ACTIVE_LOW>;
++ };
++ };
++};
++
++&spi_nor {
++ status = "okay";
++};