aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm53xx/image/Makefile')
-rw-r--r--target/linux/bcm53xx/image/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index b2a7da80c5..45355e1ec9 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -328,10 +328,12 @@ define Device/meraki_mr32
# if the partition is smaller than the old one.
KERNEL_LOADADDR := 0x00008000
KERNEL_INITRAMFS_SUFFIX := .bin
+ DEVICE_DTS_DELIMITER := @
+ DEVICE_DTS_CONFIG := config@1
KERNEL_INITRAMFS := kernel-bin | fit none $$(DTS_DIR)/$$(DEVICE_DTS).dtb | \
pad-to 10362880
KERNEL := kernel-bin | fit none $$(DTS_DIR)/$$(DEVICE_DTS).dtb
- IMAGES := sysupgrade.bin
+ IMAGES += sysupgrade.bin
# Currently the only device that uses the new image check
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
@@ -437,7 +439,7 @@ define Device/tplink_archer-c5-v2
TPLINK_BOARD := ARCHER-C5-V2
BROKEN := y
endef
-TARGET_DEVICES += tplink_archer-c5-v2
+#TARGET_DEVICES += tplink_archer-c5-v2
define Device/tplink_archer-c9-v1
DEVICE_VENDOR := TP-Link
@@ -449,6 +451,6 @@ define Device/tplink_archer-c9-v1
TPLINK_BOARD := ARCHERC9
BROKEN := y
endef
-TARGET_DEVICES += tplink_archer-c9-v1
+#TARGET_DEVICES += tplink_archer-c9-v1
$(eval $(call BuildImage))